cancel
Showing results for 
Search instead for 
Did you mean: 

Strix Flare changing profile on it's own

InFAMAS-ONE
Level 8
Hi there guys.

I bought this keyboard about a month ago, and it has been great up until the last update in crate.

It has started randomly changing profiles on its own - happens a lot when I'm gaming, and it's starting to drive me crazy. I have found that using the lock/media/brightness keys and volume wheel at the top of the keyboard will also cause it to do it.

I have tried resetting all profiles to default in Armoury crate, as well as doing the hardware reset by holding down FN+ESC. I have also tried a fresh install of Crate, as well as reverting to a system image that was created when everything was working properly and none of this has fixed it. Crate says my system is up to date, and all my other devices are unaffected by this issue.

Here are a couple of short videos to illustrate what I'm talking about. Sorry if I sound a bit frustrated in them, but I honestly have no idea what has caused this, or how to fix it.

https://youtu.be/iZGdTKQk1GU (Part 1)
https://youtu.be/vILnN8TTbQQ (Part 2)

I would like to add that I had not played around with any of the profiles before this started happening. Any alterations to the profiles were in an effort to stop it doing this. I also don't use the scenario function of Crate. When I bought the keyboard, I just plugged it in, selected the Aura effect I wanted, and synced it with everything else - it worked perfectly! I have been able to use the lock/media/brightness keys previously and it's had absolutely no effect other than what they're supposed to do.

I'm guessing this is a firmware issue, but I'm lost on how to fix.

Thanks for reading, and I'd appreciate any help on this.

Edit: I thought I'd just try uninstalling crate and observing the keyboard's behaviour. With crate uninstalled, I can switch profiles manually and guess what! - Everything works perfectly again. I obviously don't have the use of Aura sync, or control over profiles etc if I want to modify anything, but it is no longer switching profiles on its own, and it doesn't switch profiles when I use the media/lock/light keys either! Looks like an error in Armoury crate itself is causing the keyboard to misbehave. I reinstalled crate again after using the uninstall tool to remove it, restarting, doing registry clean, and checking windows for intergrity violations. As soon as I restarted after installing crate, same issue again.

Item Version
---- -------
Armoury Crate UWP App 3.1.6.0
ROG Live Service 1.1.6.0
AURA Service (Lighting Service) 3.04.22
Armoury Crate lite service 3.2.4
ASUS AURA Extension Card HAL 1.0.24
ASUS Keyboard HAL 1.01.35
ASUS Mouse HAL 1.1.0.27
ASUS MousePad HAL 1.0.2.3
AacVGA 0.0.3.0
KingstonDram 1.0.28
AURA DRAM Component 1.0.54
ENE RGB HAL 1.1.28.0
PHISON HAL 1.0.6.0
Patriot Viper DRAM RGB 1.0.9.1
Patriot Viper M2 SSD RGB 1.0.6.3


cheers.
279 Views
39 REPLIES 39

Just picked up a Flare, delivered today (refurbished on eBay) with the silent red keys. LOVE this keyboard, wow. THIS is typing!

Configured it with colors & effects as I like for now:
87083

Looks like:
87084
(although I'll probably darken them a bit).

With white lasers coming out from each for effects...

When I too ran into the media keys / reset profile back to default issue. So glad Google found it's way to this page, as I will be camped on it awaiting an update.

Dear ASUS ROG,

Thank you so much for the fix, it's nice to have my keyboard working properly again 😄

All the best guys.

MasterC
Community Admin
Community Admin
There will be a slight delay for this, but rest assured, there will be a solution (estimated time: 1-2 weeks).
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
There will be a slight delay for this, but rest assured, there will be a solution (estimated time: 1-2 weeks).


Could you tell me please if my issue is a hardware problem or firmware ou software and if is know this issue i would be apreciate for your explication
Thanks

MY ISSUE IS EXPLAINED WITH TWO PICTURES IN THE 2ND PAGE OF THIS TREAD

I got the exact same issue with the Rog Strix Scope Deluxe.

Gold Kris wrote:
I got the exact same issue with the Rog Strix Scope Deluxe.


Thanks a lot friend i got the keyboard flare for a week i don´t know if was a issue from hardware or it was the software i tried to read in internet but nothing talk about it thank you very much for your help

Regards

Does your profile change when F-keys are pressed?? (F-Lock disabled)

Gold Kris wrote:
I got the exact same issue with the Rog Strix Scope Deluxe.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ROG wrote:
Does your profile change when F-keys are pressed?? (F-Lock disabled)


Yes, but I just got an update for the ROG Strix Scope TKL and it is fixed. 🙂

MasterC@ROG wrote:
There will be a slight delay for this, but rest assured, there will be a solution (estimated time: 1-2 weeks).



You said there would be firmware update this week!
Do you mean that we should wait any longer?
3 weeks have already passed. :galen:
Every gamer has suffered from small-screen videos

The Flare just got a HAL update today but it didn't change anything. 😞