Showing results for 
Search instead for 
Did you mean: 

ROG Strix Scope RX EVA Edition issue - I can't press any key other than the top ones

Level 7
Hi, first time using a forum since forever, I hope I am doing this right but if I am missing info to give or am posting in the wrong place do tell me. I had to wait for days to be able to post.

So some backstory: I've gotten this keyboard for months already and it's my first mechanical keyboard. A week ago, I was just playing a game (Duskers) when all of the sudden made the game into window mode. I figured I might've pressed "Alt+Enter" by mistake so when I tried that it started to minimize the game. Then after a few other keys were pressed later it started to open apps constantly which made me power off my PC in fear that I might've caught some virus/malware. Fast forward, after fully reformating my PC. I found out that the keyboard was the issue. Plugging this into another PC seems to be showing the same issue.

So the issue right now is that, other than the top keys: "ESC" until the "ScrLk" key all other keys are unresponsive. I found this out after changing the lighting to "Reactive", every key seems to light up like it's being pressed. Also, when pressing any of those workable keys, it starts opening apps like a script: Google chrome constantly opens 3 sites constantly: "yammer/Microsoft login/LinkedIn", The mail app, OneNote, and some emote menu that I didn't know existed at the bottom-right of the screen. I can somehow stop it by spamming "F1 to F4" or holding down "ESC". So if I don't press any of those keys, I am able to head to the armoury crate and view my device there as normal.

So I've tried so far:
- Reset my profile and such already with no luck.
- Factory reset (Holding FN+ESC) doesn't seem to work since the FN key doesn't seem to work.
- I am able to change the keys of the workable keys through the armoury crate to something so that I can try the alt+window that I thought might have been the issue which was not. I couldn't bind an FN key somehow. Unless there's a way that anyone knows, I may be able to do that factory reset.
- I made sure to check if there are macros that were set in the armoury crate but I didn't find any being set up.
- Recently, I've checked some keyboard tester sites after stopping the script opening app and saw that the keys: "`,1,2,3,4,5, Lshift, Lctrl, windows, Lalt, Ralt, Rctrl, Rshift" are being held.
- I Currently searching if it's a firmware issue and to see if I can roll back to an early one to see if it does anything. There doesn't seem to be any tutorial on how to do it for this keyboard so I am hesitant.

I don't think the game I was playing at that time caused it but I am unsure. Just in case, if someone wants to try to see if they can replicate it. I got that for free in Epic Games that week, not sure if it's still up since I still don't have most of the apps installed.

I haven't gotten any virus/malware problems for years since I am quite thorough with scanning and checkups.

I really hope it's just some kind of key combination that I might've pressed by accident and someone knows how to undo this as I am running out of ideas on what to do. I don't think the keyboard could get some virus/malware or can it? Please help.


Ok great, you got it sent off for an RMA.

Let me know how it goes when you get your new keyboard.


@Nate152 wrote:

Ok great, you got it sent off for an RMA.

Let me know how it goes when you get your new keyboard.

I didn't go for the keyboard replacement since they explained to me that the product of the same design is EOL so I went for the buyback/refund option.


Hello Cruelkingat89,

Have you tried all the suggestions in this thread?

If you have and nothing helped, I will also have you contact ASUS technical support for further assistance.


I have tried the recommendations but it still does not work 😭



The ASUS technical support phone number for your region is 800-835-994.

Level 8

i fixed the problem, i had to connect the keyboard to armory crate, which was a bit difficult since the keyboard would not stop pressing keys. once updated by the tool it is back to normal

That's great that you were able to fix it.

I was able to update my keyboard multiple times in the armory but that issue still persists. They might've found a fix after I RMA mine so I will never know if that would've fixed mine. 😓


Awesome, good to hear you got your ROG Strix Scope EVA Edition updated.

Thank you for reporting all is well.

Level 7

Sorry of my poor english at first. I had exactly the same issue. My PC was in idle and suddenly start to opening apps and typing "itself".

I bought the keyboard in january and two month later I got the problems.

My keyboard is in local ASUS service actually but no response since a month...


Hello LsrLrd,

Give them a ring and ask for an update on your RMA.

Let us know how it goes when you get your keyboard back.