cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Scope RX EVA Edition issue - I can't press any key other than the top ones

Skyed
Level 7
Hi, first time using a forum since forever, I hope I am doing this right but if I am missing info to give or am posting in the wrong place do tell me. I had to wait for days to be able to post.

So some backstory: I've gotten this keyboard for months already and it's my first mechanical keyboard. A week ago, I was just playing a game (Duskers) when all of the sudden made the game into window mode. I figured I might've pressed "Alt+Enter" by mistake so when I tried that it started to minimize the game. Then after a few other keys were pressed later it started to open apps constantly which made me power off my PC in fear that I might've caught some virus/malware. Fast forward, after fully reformating my PC. I found out that the keyboard was the issue. Plugging this into another PC seems to be showing the same issue.

So the issue right now is that, other than the top keys: "ESC" until the "ScrLk" key all other keys are unresponsive. I found this out after changing the lighting to "Reactive", every key seems to light up like it's being pressed. Also, when pressing any of those workable keys, it starts opening apps like a script: Google chrome constantly opens 3 sites constantly: "yammer/Microsoft login/LinkedIn", The mail app, OneNote, and some emote menu that I didn't know existed at the bottom-right of the screen. I can somehow stop it by spamming "F1 to F4" or holding down "ESC". So if I don't press any of those keys, I am able to head to the armoury crate and view my device there as normal.

So I've tried so far:
- Reset my profile and such already with no luck.
- Factory reset (Holding FN+ESC) doesn't seem to work since the FN key doesn't seem to work.
- I am able to change the keys of the workable keys through the armoury crate to something so that I can try the alt+window that I thought might have been the issue which was not. I couldn't bind an FN key somehow. Unless there's a way that anyone knows, I may be able to do that factory reset.
- I made sure to check if there are macros that were set in the armoury crate but I didn't find any being set up.
- Recently, I've checked some keyboard tester sites after stopping the script opening app and saw that the keys: "`,1,2,3,4,5, Lshift, Lctrl, windows, Lalt, Ralt, Rctrl, Rshift" are being held.
- I Currently searching if it's a firmware issue and to see if I can roll back to an early one to see if it does anything. There doesn't seem to be any tutorial on how to do it for this keyboard so I am hesitant.

I don't think the game I was playing at that time caused it but I am unsure. Just in case, if someone wants to try to see if they can replicate it. I got that for free in Epic Games that week, not sure if it's still up since I still don't have most of the apps installed.

I haven't gotten any virus/malware problems for years since I am quite thorough with scanning and checkups.

I really hope it's just some kind of key combination that I might've pressed by accident and someone knows how to undo this as I am running out of ideas on what to do. I don't think the keyboard could get some virus/malware or can it? Please help.
4,325 Views
19 REPLIES 19

Nate152
Moderator
Hello Skyed,

Welcome to the ROG forum.

You're in the right place and sorry to hear you're having issues with your ROG Strix Scope RX EVA Edition keyboard. Thank you for all your information, the more detailed you can be about the problem, the better we can help you.

One thing that stands out is, trying on two pc's with the same result could point to a faulty keyboard, but let's check and try some things.

1) When you say you fully formatted your pc, do you mean a fresh windows 10/11 install? Normally, this will fix any problem.

2) Try running the windows keyboard troubleshooter, does it pick up anything?

3) Uninstall your keyboard from Device Manager and reboot, then check to see your keyboard is working properly, it will show under Mice and other pointing devices.

pic - 97582

4) Fn+Esc keys should reset your keyboard, you can also reset each profile individually in Armoury Crate.

5) The ROG Strix Scope RX EVA Edition supports on the fly recording, so it's possible you may have made some Macros and wasn't aware of it. In Armoury Crate, double check and delete all Macro profiles.

6) For good measure, you could try using the Armoury Crate uninstall tool and reinstalling/updating Armoury Crate. To use the uninstall tool, click the link below and select your operating system, click "Show all" in blue, the uninstall tool is the third download.

https://www.asus.com/supportonly/armoury%20crate/helpdesk_download/

Once uninstalled, install version 3.2.5.2 (first download) then head to the update center. What version does Armoury Crate update to?

7) Check in windows keyboard settings Filter keys are turned off.

😎 Try different usb ports 2.0 - 3.0

Does any of these suggestions help?

Hi Nate152,

Thanks for replying. Sadly none of the suggestions seems to work on fixing the issue. The keyboard is working but only a few keys are at the top. I am attempting to include screenshots in this post to help get a visual idea of some of the things that I said earlier.
--------
Answering the numbered questions:
1) Yes, a fresh windows 10 reset. All data was removed to be sure but it didn't fix the keyboard. Granted that I had the keyboard unplugged as I went with that option.

2) Nothing, when I went to advance and choose the keyboard it says nothing was wrong.

3) The screenshot doesn't seem to work but I did go and uninstall the device and restarted it. Still the same issue.

4) Like I mentioned initially. All keys except the top ones don't seem to respond when pressed. I did use the armoury crate to reset all profiles and sync them as well but the issue persists.

5) Macro profile was empty. I deleted the sole macro profile and the macro-like opening of the apps still happens.

6) I did this before but I did it again while following your step. It's updated to the same one before I uninstall: "Versions 5.4.10.0"

7) Filter keys are unchecked and all of the other options are in there.

😎 I plugged it into all the USBs I have. Still the same. (I have the Asus Gundam edition set as a PC tower)
----------
Screenshot of Taskmanager: This shows what apps open when I initially press the top keys

Screenshot of ReactiveLights: So the working keys are the ones that don't have the lights on.

Screenshot of KeyboardOnlineTest: This is what seems to be pressed when I somehow stop the macro-like app opening. The top keys can still be pressed normally (Esc, F1, F2... etc)

Nate152
Moderator
Ok,

Let's check to see what language and layout windows is using, I would think yours should be Canadian Multilingual Standard - QWERTY

You can add this if it's not already set.

This is what is currently on that page.

Edit:
- I went and install the Canadian French language and it did nothing as well. All other keys still are unresponsive and remain lit up when it's supposed to be unlit when in reactive mode.
- I also delete and download the same keyboard language.

Nate152
Moderator
Thank you,

Your layout should work as the top row of your keyboard letters are Q W E R T Y.

Since the windows layout looks good and none of the suggestions helped, I'll have you contact ASUS tech support for further assistance. They will probably have you try some things then have you set up an RMA. If they are able to fix the problem, please come back and report your solution.

If they can't fix it, is your keyboard still under warranty? The warranty is good for 1 year from the purchase date.

Click the link below and scroll down to Contact Us - ASUS Live Chat

https://www.asus.com/ca-en/support/

The Asus site says that I am still under warranty. I'll head to the live chat tomorrow.

Do I just link this forum thread to them or do I need to explain everything at the beginning?

Nate152
Moderator
Ok great !

Ask for help with your keyboard, you can mention you asked for help here and couldn't solve the problem. As you suggest, you can post them a link to this thread to show all the troubleshooting you've done.

Have your serial number and proof of purchase on hand, they will want these for an RMA.

So they were not able to fix it and I sent it to RMA. After some email back and forth I went with the buyback option since the product was deemed EOL.

In any case, thanks for the assistance throughout this Nate152. I am unsure if I am supposed to close this topic or do something.

same problem for me, any solution?