cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX SCOPE NX DELUXE WIRELESS - FN and other keys not working

soulnrgizer
Level 7

 

I bought this keyboard and after a few days of regular use some of the keys don't work anymore.

The UP, DOWN and RIGHT arrow, Insert, Delete and FN keys are not responding, whatever link I set (wired, wifi or BT, even on another computer), even when in BIOS.  

Another odd behaviour is that the keyboard doesn't turn off the lighting anymore by itself after 1 minute as per setting in Armoury Crate.

Browsing similar issues i tried the main solutions (uninstalling Armoury Crate, uninstalling through Device Manager, etc.).

The only thing I couldn't try is the factory reset, FN + Esc for 10-15sec has no effect since the FN key is not working.

Is there any workaround to trigger the factory reset? If not, I think my only option is to send it in RMA.

 

Thanks in advance for any advice.

110 Views
3 REPLIES 3

Nate152
Moderator

Hello soulnrgizer

Try resetting your keyboard in Armoury Crate.

Reset.png

 

 

 

 

 

 

Hi Nate152,

I tried but after the reset nothing happens.

Did you ever figure it out? 2 month old and the 3 key has stopped working. About finished with Asus tbh.