cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Scope ii 96 wireless Keyboard Not Working in Wired Mode

Satiskopat
Level 7

Hello, I recently bought a ROG Strix Scope II 96 wireless keyboard, and I'm really loving it, but I cannot use it in wired mode anymore.

Bluetooth and wireless mode work without any interference, but with a USB connection, it only charges.

I have already tried:

  • Different USB ports
  • I verified both ends of the cable.
  • Verified the USB cable is working with another device.
  • Connecting to another computer 
  • Resetting the keyboard in wireless mode (FN+ESC)

I cannot see this screen in wired mode. What should I do? Is there a fix for this?

Satiskopat_0-1714593606681.png

 

447 Views
11 REPLIES 11

Silent_Scone
Super Moderator

Hi @Satiskopat  Ensure the Connection Switch (5) is set to the middle position for Wired Mode.

Silent_Scone_0-1714601619316.png

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi, thanks for the reply, but in this case, I didn't forget to do that. It is set in the middle position. 

Nate152
Moderator

Hello Satiskopat

Are you using the original cable that came with your keyboard?

Have you tried reconnecting the cable to your keyboard and a different usb port on your pc?

 

 

Hello, yes I'm using the original cable. I tried other usb ports and other computers. My keyboard does not work with none of them with wired connection. 

Nate152
Moderator

Thank you for clarifying.

Set your keyboard up in wired mode, then run the windows keyboard troubleshooter.

Does it give any information about the problem?

keyboard troubleshooter.png

Unfortunately, it couldn't detect any problems.

"Hiçbir değişiklik veya güncelleme gerekli değildi" Means no necesary to update or change.

Satiskopat_0-1714914865285.png

 

Nate152
Moderator

Thank you

I'm not sure why it wouldn't be working in wired mode and since trying on another pc gives the same results, I'll have you contact ASUS Technical Support.

This is the phone number I came across for your region.

+90 216 521 46 01

Let us know how you make out.

 

 

I had the same issue but found the fault was that the multiwheel button on ther left was on a hair trigger and would trigger and sometimes not respond.

I fixed the issue by disabling custom as its when the keybaod is on the letter~ "M" that this would happen and the keyboard would suddenly not respond.
I'd have to try lift the key enough so it was not pressing on the switch. then switch it out of Custom or M on the led then it would work.

Diabling Custom will help stop the jamming up but it's still randomly select multiwheel modes frequently.

 

Nate152
Moderator

Hello Shadow_Chaser

Can I ask what you had the Multiwheel set as a custom function?

Is the letter M sticking on your keyboard?