cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Flare II Animate - UK Layout Keys no longer working

Kestami
Level 9

HI,

I'm having an issue that I've just noticed that must have started happening within the last few days, almost identical to this:

https://rog-forum.asus.com/t5/gaming-keyboards/rog-strix-flare-ii-animate-uk-layout-keys-no-longer-w...

Essentially, the forward slash and hash key aren't working. I've tried all the fixes in that post but nothing has fixed it (deleting keyboard in device manager, reinstalling armoury crate, holding function + escape to reset the keyboard, trying it on two different devices).

I've noticed a few things

1) In armoury crate, it's showing the US layout, where the forward slash and hash/pound key aren't present

US layout in crate.png

I found a file at C:\ProgramData\ASUS\ROG Live Service\DeviceContent\ROG STRIX FLARE II ANIMATE with the name ROG STRIX FLARE II ANIMATE_EU that looks more like what I'd expect to see

ROG STRIX FLARE II ANIMATE_EU.png

2) I've also noticed in a config file here C:\ProgramData\ASUS\ROG Live Service with the name deviceinfo.ini it seems that my keyboard is being set to US layout (I can't seem to change this to UK or GB with any effect)

[ROG STRIX FLARE II ANIMATE_0B0519FC]
Name=ROG STRIX FLARE II ANIMATE
DisplayName=ROG STRIX FLARE II ANIMATE
DeviceType=Keyboard
LStype=Keyboard
Layout=US

--other config

 

I'm not sure what actions to take. I've seen other posts about manual firmware being handed out, is it possible to try something like this?

Thanks!

527 Views
7 REPLIES 7

casparit
Level 9

I have exactly the same problem with my Rog Strix Flare II animate. Those two keys don`t work due to the layout in Rog Live Services  being US and not EU. The keyboard works despite the two keys (forward slash and hash key). I need the qwertz keyboard layout for Germany, but in aura sync it is set to US (qwerty). At first, the two keys did not light up when setting up a profile in aura creator, but after a while, that worked. I recieved the keyboard yesterday and made instantly the firmware update via aura sync, then the problem was there. I've tried every possible solution, but no success. The keyboard needs a firmware update with the qwertz layout.

Kestami
Level 9

Sounds like we're both in the same boat, I tried for a few hours to fix it but nothing seemed to work. I wonder if a new version of Armoury Crate thought they the keyboard was US layout because of some bug and updated the keyboard firmware with US firmware. There doesn't seem to be any way to roll it back so hopefully someone from Asus or a moderator can give us a solution here, quite frustrating at the minute as I use these keys often!

casparit
Level 9

Yes seems so, so we need help form a moderator to supply us with a solution (EU-firmware, update tool e.g.). I had some struggle with Armoury Crate yesterday, it runs again, but the keyboard stays in the US-layout. Perhaps one could retry the firmware update manually, I'm sure the file must be stored on our computers while the update was carried out. So please Asus, help us.

Kestami
Level 9

Was hoping for an update or response by now from an admin or the likes...do we need to take an alternative route to get this sorted?

I posted the issue yesterday under Rog care peripherals. I had also contact with the asus support, they promised to talk to the developers of armoury crate. Perhaps you could also contact the asus support?

Kestami
Level 9

Sorry, i'd been away for a couple of days. I'll try contact support as well, did they get back to you at all?

casparit
Level 9