Showing results for 
Search instead for 
Did you mean: 

ROG Strix Flare II Animate firmware error

Level 7
Recently purchased new keyboard to replace keyboard that got liquid pored on it.

upon connecting it, it strataway asked for a Device firmware update
is had an error and now asking me to go to down load centre and reset firmware

but seem to be stuck in a loop

anyone have a file I can reset the keyboard with ?



Level 7
Well after many many tries unsuccessfully I unplugged and tried on l ROG laptop which did not see any firmware updates

connected to another desktop PC which did see the firmware update, this time when firmware started I got a boot loader to start too
My normal PC still thinks Firmware needs to be updated but can see it has now updated

Level 12
I had problems with the last firmware update, too.

With prior version of AC, attempting to access the Animate-II page gave an error saying a "core service" needed to be updated. Clicking "Update" would close AC, bring up an update dialog, declare success, then restart AC. Further attempts to access the Animate-II page resulted in the same "loop", over and over. Trying to install the update from the "Update Center" screen gave the same result.

After upgrading AC to, I still had the same issue. I uninstalled AC using the uninstall tool, and reinstalled it. I was then able to perform the update. However, AC kept telling me an update was needed. Sometimes I could access the Animate II page, but most times it would tell me an update was required, over and over.

What I *think* fixed it was this: Once I was able to get to the Animate II page, I went to the "Firmware Update" tab there and clicked "Check Update". This just took me to the Update Center again, where I clicked "Check for Updates" again -- and it found none, because everything was up-to-date. But since then, I can consistently access the Animate-II page without any problem. I don't know if this different "route" to the Update Center fixed something, or if AC just finally overwrote whatever was causing the problem. But you might give that a try, assuming you can get to the Animate-II page and it's "Firmware Update" tab.

For reference, here are the component versions installed for mine:
Z690-E, i9-12900k, 2x16 DDR5, 980pro nvme x3, Ryujin-II 360, Strix Animate-II, Evga 3090 ftw3

Hello g_rowell,

Armoury Crate shouldn't be showing two ROG Strix Flare II Animate keyboards, try using the Armoury Crate uninstall tool and reinstalling.

In the link below select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Once uninstalled, install Armoury Crate version then head to the update center.

The latest version of Armoury crate is, it will update automatically during the reinstall.

How does it go after using the uninstall tool and reinstalling?

pic - 97868

Level 7

Had to connect Keyboard to another Computer, once this was done update was able to be completed.

@Nate152 second keyboard only appeared after attempting to update keyboard firmware failed each time.


Have you used the Armoury Crate uninstall tool?

If you have and it didn't help, please provide a list of your pc hardware.