cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Flare Died

apha71
Level 7

Hey I have a ROG Strix Flare that is not showing in Armoury Crate, and is not working period. Caps, Num and Scroll  lock LEDs flash once a second. Is this a firmware issue? If so how can I fix?

497 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Nate152
Moderator

Sorry to hear resetting your ROG Strix Flare didn't help.

Check your messages at the top right of the forum page.

 

 

 

 

View solution in original post

7 REPLIES 7

Nate152
Moderator

Hello apha71

Try resetting your ROG Strix Flare by pressing and holding the Fn + Esc keys for 10-15 seconds.

 

 

 

 

 

I tried that yesterday when I was reading the forums, before I posted. Tried it again today with no success.

Nate152
Moderator

Sorry to hear resetting your ROG Strix Flare didn't help.

Check your messages at the top right of the forum page.

 

 

 

 

Thanks that has fixed it! I am using it to type this message now, thank you!

Nate152
Moderator

STARSIEGE1
Level 7

My ROG Strix Flare died too, NUM Lock led flashing at 1 second interval. Tryed to find firmware.bin file, with no success. BTW, entering flash mode is very easy, whithout opening the keyboard at all. Just unpell right down triangle rubber leg of keyboard, and voila - there is hole to press the button with pin or something...

If anyone has a firmware, I will be glad to send it to me. Thanks in advance!

Nate152
Moderator

Hello STARSIEGE1

Check your messages at the top right of the forum page.