Showing results for 
Search instead for 
Did you mean: 

ROG Claymore II

Level 7
Hello guys. I just got ROG Claymore II keyboard [RX blue], and it's AWESOME! But i can't seem to update firmware. I will put the message i get from ARMORY II V5 in attachments. I'm doing what it asks, but it's always the same message. I don't intend to use this keyboard in wireless mode, only over usb (Type-c to Type-c, since my motherboard have a Type-c port). Thanks for any help! ❤️


We'll definitely look into it, thanks!

Tekamine wrote:
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

Changing USB ports worked for me.

Community Admin
Community Admin
We confirmed this. ASUS Display Widget has a function which uses Ctrl + Alt + E as the default hotkey, what you can do is modify the hotkey to avoid this conflict.
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

Hi einkaufak

Welcome to the ROG forum.

Try resetting your ROG Claymore II by pressing and holding the Fn+ESC keys for 10-15 seconds. If that didn't help, use the uninstall tool to uninstall Armoury Crate and try reinstalling.

From the ASUS Support Center, select your operating system and click Show all in blue, the Armoury Crate uninstall tool is the third download.

Once uninstalled, install Armoury Crate version and check for updates at the update center, the latest version of Armoury Crate is

Click the pic to make it bigger.


Hello everyone.

I tried to update the ROG Claymore II keyboard firmware (the new firmware was notified to me today by the program Armoury Crate), but every time I try to update the firmware, I get this error message:

Encountered error trying to identify the firmware version.
Please reconnect the device, and click "Check for Updates" to try again.

I've already tried resetting the keyboard and uninstalling and reinstalling Armoury Crate, but the situation doesn't change...

My actual firmware is: 30.83.04

Keyboard version: 30.43.03
Keypad version: 2.00.02

How can I solve the problem ?

Thanks in advance.