cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Azoth won't go into pairing mode for slot 1.

Namorian
Level 8

Hello,

I literally just got my keyboard unpacked and tried to set it up with my devices. I connected it with my PC but tried to remove the hardware through windows. Now the keyboard won't go into pairing mode (this is all on bluetooth) for slot 1. 

Is it stuck in a loop, thinking it is connected to the device while the device doesn't find it anymore?

Would be a real shame. 

Thanks in advance.

345 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Namorian
Level 8

I actually may have found it out on my own. I didn't realise the rocker button is also a press. That should do it I think!

View solution in original post

6 REPLIES 6

Nate152
Moderator

Namorian
Level 8

Hello Nate, 

Thanks for responding so quickly.

It's about bluetooth mode. For some reason I cannot pair the slot 1 with a new device. It's like it thinks it's connected (I know tech doesn't work that way) and won't go into pairing.

I am following the instructions from the manual. I long press the button, the pairing/switch host screen comes on. When I switch to host 1 and press the button again it won't go to pairing. 

Namorian
Level 8

I actually may have found it out on my own. I didn't realise the rocker button is also a press. That should do it I think!

Nate152
Moderator

To pair with bluetooth....

1) Unpair your ROG Azoth from the Omni Receiver.

2) Open the windows Bluetooth page and make sure Bluetooth is turned on.

3) At the top click Add device and click Bluetooth.

add a device.png

4) Press and hold the button below the control knob until it shows BT pairing/Host switch.

5) Push the control knob forward until it shows Bluetooth 1.

6) Immediately push straight down on the control knob, your ROG Azoth should appear in the list of Bluetooth devices.

Azoth Bluetooth.png

7) Click your ROG Azoth and it should pair to Bluetooth.

Azoth Bluetooth.png

 

 

 

 

Nate152
Moderator