cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Azoth recent firmware

Erik71
Level 7

hello, since the most recent firmware update my 2.4  wireless doesnt work anymore, wired via usb was working now all i can get to work is bluetooth, have uninstalled reinstalled armory crate (knew that wouldnt work),  its the firmware, is there a way to manually download the firmware and reinstall it see if that helps? armory crate dont give me an option as it shows the most recent update 4.00.07

1,030 Views
21 REPLIES 21

twinblade02
Level 7

Hey mate. I just got an Azoth today - was having a similar problem but with both the wireless and wired mode. Basically, I had no functionality in either, except on BT mode. I'm of the opinion that it is the combination of 2 things:

1) The stock wires that you get and the base firmware.
2) The amount of resources devoted to connected peripherals.

I used to run a Logitech G916 TKL before this, so I was dead certain that my (mother)board has no issues with connectivity, nor does it have any driver errors. Now, back on topic to what I did.

The stock wire that you get with the Azoth - both that and the extension dongle and receiver are terrible. I located a free USB 3 port and connected it to that - no dice. So I uninstalled Armory Crate, then reinstalled it. Once I was certain the software and the keyboard were talking to each other on BT (I still had that issue), I connected a spare USB-C (Thunderbolt) cable to the keyboard, and boom - I got the board to start talking to me. For some reason, the stock wires I got are either defective or something or there was a driver issue somewhere down the line. Next, I went to the website and downloaded the AutoUpdater package; then went back to Armory Crate and ran a sweep for updates. Install all of them.

Once that's done, head to the option for the Azoth (when you have a wired connection), then check for a firmware update. Install it.

Once all that's done, run that AutoUpdate software for the dongle. Make sure the board is on wired mode, and that you at least have a spare USB 3.0 port that you can use to connect the dongle and the receiver. Run that exe file and update.

 

Hopefully by now you'll have a functional keyboard. Hit me up if you have a problem.

The only problem I seem to have at the moment is that I cannot get the board to talk when its on the wired mode and connected to the PC using the wires ROG gives us in the box. I have to disconnect it and use it on that USB-C cable for it to work. 

 

Which website did you go to for the AutoUpdater Package? The wire that came with my keyboard is still working and bluetooth is fine but I’m also experiencing issues with the dongle since the recent update.

Same website where you download the driver and firmware from. Look for the Azoth in the support section, navigate to the tab that says "BIOS/Firmware" or something similar. 

I’m sorry I’m new to this. I just used AC to update my keyboard. I didn’t go to any site. I’ve tried navigating this site but couldn’t find anything. Thank you for your help.

Edit: upon browsing on a pc i found it am currently downloading and trying it now 

Edit 2: THANK YOU SO MUCH! It worked! Apparently azoth is eligible for the omni-receiver now which is why that update on the website was needed! Makes me wonder why we had to go to the website downloads instead of it just being available in AC. What the heck even is the point of AC…

I have the same issue and managed to update to Omni receiver but now I cannot pair my Azoth with the receiver. How did you do it? If I try to pair it in the Omni receiver tab in AC nothing happens and the pairing times out and ultimately fails

twinblade02
Level 7

lmao no problem. I don't know why ROG chooses to do things like this - but its pretty clear that they need to overhaul AC completely. The software is just terrible.

Anyway, I'm glad you got things sorted out.

Furry_Denis
Level 7

I also faced this problem after the last update, I have a wired connection and 2.4, but when you switch to 2.4, the keyboard stops lighting up, and in armory crate, the keyboard connection picture disappears and ASUS omni resevre, I did everything to make everything work, but nothing it didn't work!!

Did you solve this? I got the same issue, managed to upgrade the receiver to Omni but now it won't pair with the keyboard, I can only use Bluetooth and usb. Tried a clean reinstall of armoury crate, reforce update firmware of receiver, checked all updates are applied, tried on another computer...

Yes on tgd website they have the firmware to download did that and works fine now