Showing results for 
Search instead for 
Did you mean: 

ROG Azoth keeps disconnecting from Armoury Crate, resulting in various issues

Level 8

My ROG Azoth keyboard keeps getting disconnected from Armoury Crate resulting in a "we are sorry, there is an error with the device page" message when trying to access it in Armoury Crate.

This causes a few problems:

  • The "adaptive color" RGB option gets stuck and stops updating.
  • Scenario profiles get stuck and stop updating.
  • The RGB configuration, keyboard settings, macros, etc. freeze and cannot be changed.

The only temporary fix I've found is switching the keyboard from wired mode to wireless, and then back to wired mode. This briefly fixes the issue, though it regularly occurs every 10-30 minutes.

Things I've already tried:

  • I exchanged my previous Azoth keyboard through Amazon for a new one because I thought it may be a hardware issue. This exact issue has occurred on both keyboards.
  • I reinstalled Armoury Crate numerous times.
  • I reset the keyboard using FN+ESC numerous times.
  • I swapped USB ports and USB cables.
  • I've tried the keyboard on an entirely different PC and it still occurs.

One other important note is that I tried both SignalRGB and OpenRGB for troubleshooting purposes, and the issue still occurs with those - even with Armoury Crate uninstalled - where the RGB becomes unresponsive after a short period of time. This leads me to believe it's a firmware issue of some sort, but who knows.

Armoury Crate, the firmware, my BIOS, drivers, and Windows are all up-to-date.

I have a log file attached.


Level 8

Did a full Windows reinstall. Still happening.

New log file attached.

Community Admin
Community Admin

The logs were passed to the engineers for inspection, thanks. In the future, please submit a form for each issue and indicate in the official issue reporting thread (as you have already done), you may choose to provide updated logs and screenshots to the form at a later date.

The new log should help, the previous log (submitted in Google Forms) appears to be truncated or corrupted.

FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Level 7

Same thing happens to me both on ROG Azoth and ROG Harpe Ace Aim Lab mouse, but not both together at the same time. Sometimes is the keyboard sometimes is the mouse. They are randomly disconnecting from Armoury Crate. Using them on wireless mode with USB DONGLE on an Intel Nuke 12 Pro with Windows 11. All of them are updated to the latest firmware. Using Armory Crate 5.8.0.  After a PC restart the problem disappears for a day or two then happens again. Did reinstall my USB drivers but after some time goes again and shortly disconnects.