cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Azoth battery not updating

Digi
Level 7

I have seen that more people have the same issue of some kind and I am sadly one in the bunch. 

I have had the keyboard for 1 week and I had it on wireless while gaming, and it just stopped working slowly (not reacting to me pressing the move keys and then working for a second and then not) 

I looked at my battery and it hasnt changed once from 100% and even while it said at 1 point battery low it says 100% 

I have checked for updates, I have tried plugging it in and checking if it will catch itself having issues. Apparently im up to date on updates and I am not sure what else to do.

Its been a blast to play with this keyboard as I have sensory issues and get overwhelmed so this keyboard has helped a lot 😭

828 Views
8 REPLIES 8

Nate152
Moderator

Hello Digi

Do you have the wireless dongle connected to a pc usb port?

 

 

 

hi yes I have it connected to my motherboard. It worked fine first few days but as stated above, battery never change. not im AC nor on the keyboard.

Nate152
Moderator

Thank you

Let's make sure your ROG Azoth is updated.

Try this.....

1) Reset your ROG Azoth by pressing and holding the Fn + Esc keys for 10 seconds.

2) Let the wireless dongle connected to your pc.

3) Connect the cable to your ROG Azoth and your pc.

4) Set the wireless switch on your ROG Azoth to wired mode (switch set to the center position).

5) Go to the Armoury Crate update center, you should see an update for your ROG Azoth, click the update button.

If the update is successful, check the power tab to see the battery percentage and if it has changed.

 

Azoth Battery.png

 

 

Hello! I still have the same problem (https://rog-forum.asus.com/t5/gaming-keyboards/rog-azoth-battery-level/m-p/954334) and nothing seems to help. What I tried:

  • Ensured I'm using the latest software (including Halloween update)
  • Reset the Keyboard (Fn + Reset for more that 3 seconds)
  • Reset the Keyboard via Armory Crate
  • Connect it over 2.4 Ghz dongle connected directly to the motherboard of my PC
  • Reinstall Windows
  • Disassembled the keyboard and replaced the battery with original replacement

and still no luck. It seems to me like there is software/firmware bug at this point.

Nate152
Moderator

Hello NDrewBy,

I saw your thread somehow got locked, I unlocked it.

So, your ROG Azoth is still stuck showing 100% Charged?

When you set the LED brightness to 100%, does it show a red border around your battery?

Unsync your keyboard from Aura Sync.

On the lighting tab, set the LED brightness to 100%.

 

LED brightness.png

 

Then on the Power tab, it should show a red border around the battery to let you know it will drain faster with the LED brightness set to 100%.  Just wondering if this is working properly.

Battery border.png

 

Here are the current versions.

ROG Azoth.png

 

 

 

 

 

 

Hello!

Unfortunately it's still stuck at 100%.

However if I set the LED brightness to 100, the red border on the Power tab appears:

power.png

I checked the software version and it seems to be the latest:

version.png

Is there any way I can perform a firmware update manually or perform some sort of factory reset (beyond profile reset with Fn + Esc)?

Nate152
Moderator

Ok, your ASUS Main SDK plugin version is showing newer than mine, but this shouldn't affect the battery status. The high battery consumption notification with the red border is working, this is good.

The only reset I know of is with the Fn + Esc keys and I don't know of any way to update other than with Armoury Crate.

Sometimes little things can get it to work.

Try this...

1) Reconnect the wireless dongle or try another usb port on your pc.

2) Next, connect the cable to your ROG Azoth and a usb port on your pc, set the wireless switch to wired mode (switch set to the center position).

Then, open device manager, right click and uninstall all HID Keyboard Device and your ROG Azoth and reboot. It should show two ROG Azoth's.

uninstall ROG Azoth.png

3) After rebooting, disconnect the cable, set the wireless switch to 2.4GHz wireless mode and check the battery percentage.

 

 

 

 

 

 

 

 

I tried all those steps. Unfortunately still no luck.