cancel
Showing results for 
Search instead for 
Did you mean: 

Faulty Switches with Asus ROG Azoth

jpirog
Level 8

I've had this keyboard for a few months now, and I love it. I saw a post a few weeks ago while I was having issues with my "G" key, someone mentioned they were getting double presses or no presses at all when typing. Their solution was to replace the switch.

I did that with mine, and it resolved my "G" key issue. I'm now having the same issue (double press or no presses) with my "ENTER" key.

Is anyone else having this issue or did I just happen to get a lemon? Also, there are 3 replacement switches, I'm already down to 1 - will support send me a few more switches since they sent me bad ones?

3,306 Views
13 REPLIES 13

Rolkam
Level 7

I have also brought the ROG Azoth and been using it for a bit over 2 months. I encountered similar issues with the switches, having either no input or double input when pressing some keys. I already replaced some with the extras that came in the lube kit (one of them was already faulty). I was looking for other sets of switches to replace the originals as it seems they are not of great quality (or maybe a bad batch) but wanted to at least check if there is any feature allowing us to increase the debounce time on key presses.
Would I be better off buying a new set of switches ?

So far it doesn't look like any Asus support employees look at these things.

tomato884
Level 7

I have the same problem. Do you have red swittches too? (btw the touble t here was a double press)

My setup is: 

- Asus Rog Azoth Red Switches

- Asus Rog Harpe Aice Aim Lab Edition

- Both connected each with a wireless dongle

I will try trouble-shooting in the next weeks, starting with:

1. turning off the energy saving mode.

2. try wired connection

edit: not helping

I noticed if you try to recreate the problem with e.g. Key + Enter in the editor it's hard to replicate if you clearly press the keys. I guess it has something to do with holding a key leads to spamming the output which is sometimes faulty. Deeply pressing the keys is not reproducing the error, so if you slam your keyboard on every press with clear pauses it doesnt show up. However this is surely not intended and I wonder if it's hardware or software wise. I also want to notice, that the last firmware update failed at my side.

tomato884
Level 7

Does anyone have this error while Armoury Crate uninstalled?

Edit: Armoury Crate doesn't make a difference. Key strokes still randomly spam the output a dozen times now. This has nothing to do with holding down a key intended to get more outputs while e.g. typing. I'm in contact with support and would like more feedback from you guys here. I could not recreate the issue on a macbook, reinstalling drivers and resetting everything on my PC didn't make a difference. 

Does anyone has 2 drivers for 1 Azoth keyboard too? Not happening on a regular keyboard.driverazoth.png

PerfectedFlaw
Level 7

I'm glad more people are bringing this up since I couldn't find much information on this online. I'll post my findings here as well. I was experiencing key chattering with a lot of switches throughout the keyboard, it wasn't isolated to one or two, 10 different keys were double typing from time to time.

I haven't tried the this with ASUS's Red switches that came with the keyboard. When I received the keyboard, I installed Akko Lavender switches because those were my preferred switches. But even with Akko Lavender switches, I'm experiencing key chatter. These switches were working perfectly fine in my GMMK Pro that I migrated from.

I too saw an earlier post about this and ASUS's support team said to try different switches on the keyboard. From there I switched my Akko Lavender switches to Holy Panda switches. I can say that the Holy Panda switches seem to be working better for me compared to the Akko Lavender switches, the keys that were chattering for me stopped repeating. BUT just today, I noticed my 's' and 'd' keys began chattering even with these Holy Panda switches, which is making me suspect that there might be some underlying issue with this keyboard. Unfortunately I don't have the GMMK Pro anymore to test my Akko Lavender switches on for further confirmation.

If anyone else has other switches lying around, I'd say try those switches to see if the key chattering goes away. I'd be interested in hearing whether the key chatter continues to occur even with new switches installed.

Hi,

I am in contact too with Asus and what helped on my site was reinstalling Armoury Crate and using the Armoury Crate uninstall tool + a windows command to identify faulty drivers. There is a tutorial by asus somewhere but I'm currently only on my phone and can't help you out.

It's imporant though to remove everything Armoury Crate related and to patch everything after reinstalling it. Always make sure to connect dongle and Keyboard simultaneously while updating anything in Armoury Crate and simultaneously use the wired mode while doing so. 

It may be that after each firmware update we need to completly reinstall Armoury Crate which sucks, but could "solve" the problem until they solve it.

Rolkam
Level 7

Hey @tomato884, sorry I haven't checked this forum in a while after posting, thinking that nothing would be done in any way. 
To answer your comments pointing the issue on either drivers, wired/wireless connection or OS: that would not be my first guess.

I'm using my keyboard to switch quickly between a windows and a mac. Double key-presses happen on the same key between the two machines be it wired, wireless via dongle or bluetooth. When that happens on a key that is really bothering me, the fix has been to permute the switch with another key that I do not use as often or that is not sensible like function keys through F7-F11.
Once the switchs have been permuted, the issue is no longer present until it appears on a new faulty switch. 
 
I do not know what to think of @PerfectedFlaw 's case, since he tried using other switches from different constructors. Maybe it is normal for switch to become 'sloppy' after a while and that the firmware is supposed to handle this to avoid double presses but this is the only keyboard I own on which this has happened, ASUS is not a small company and it's not their first keyboard either. If this is the norm they should already everything they need to fix this.

In any case, I find it wild that ASUS support suggested @PerfectedFlaw to try other switches for a keyboard that was advertised for having amazing pre-lubed switches for the high price of 300€.

jpirog
Level 8

Just FYI, I've replaced all the stock mx reds switches that it came with, with milky yellow gats. They're performing perfectly, no duplicates or missing touches.

100% fault of the mx reds that Asus has provided in this keeb.

The problem I have on my site that I couldn't reproduce the issue on paper every time 100%. E.g. if I open a notepad and type "e e e e e" and so on, no issues were showing. However in the middle of a gaming session I got this issue multiple times, especially recreatable if I really carefully press the keys. That's why I made the conclusion for myself,

- it's either software/driver related,

- that I personally or we as customers are not used to switches like that, which perform and trigger actions on such a weak weight trigger,

- that those switches are just a bad design when it comes to triggermoment and so on,

- or in the end that those switches have a super weak durability as I only began to notice these issues weeks after the first use of the keyboard and it got worse since then.

That also matches with the fact that on my site this only happened for my most used keys in my personal key bindings tab and e. Neitherless this shouldn't happen on that scale of a keyboard, that's why I sent it in to Asus and got a replacement which is on my way now. For myself I could not reproduce it on my macbook with bluetooth, but could reproduce it on windows with bluetooth, for me that was a driver issue. 

However should this problem reappear on my new keyboard I will try out different switches. Did you have any issues replacing the switches or was it as easy as advertized? @jpirog