Showing results for 
Search instead for 
Did you mean: 

Can not update the ROG Falchion Ace - Armoury Crate shows Error code: 4151.

Level 7


I purchased ROG Falchion Ace, but the Armory Crate failed to update the components.
Armoury Crate shows Error code: 4151.

Windows 11 Pro, ASUS G14,  ROG CHAKRAM CORE + ROG Falchion Ace

I found similar issue:
the screen image looks the same.

When trying to access the keyboard from the Armory Crate, it will request an update, but it will not succeed, so currently it is not possible to control LEDs etc.
Since it continues to shine intensely, I have no choice but to use another keyboard at present.

I have tried these steps. but the error still persists.

Is there any solution?

Best regards,




To update your ROG Falchion Ace.

1) Connect the cable to your ROG Falchion Ace and a usb port on your pc.

2) Connect the wireless dongle to a usb port on your pc.

3) Set the wireless switch on the ROG Falchion Ace to on.

4) Try the update in Armoury Crate.

If this doesn't help, try resetting your ROG Falchion Ace by pressing and holding the Fn+Caps keys for 10-15 seconds, then try the update in Armoury Crate.



Level 7

Hardware reset didn't work.
I needed a keyboard urgently so I bought another one.
Unfortunately, this keyboard has left me.
Thank you very much.

Level 7

bro I have a rog strix scope tkl deluxe and it does the same thing, it gives me an error updating and it won't let me do anything or synchronize it with the other asus products, what can I do to fix the problem, regards


Hello MaNia2,

Try using the Armoury Crate uninstall tool and reinstalling.

In the link below select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, install Armoury Crate version, then head to the update center and check for updates.

Does this get your ROG Strix Scope TKL Deluxe keyboard to update?

Same problem here with the ROG Strix Scope TKL Deluxe keyboard, I can't update error 4151




Thanks @Nate152, this worked perfectly for me.  -- I had the 4151 error installing a Falchion on my ROG Strix G513QY laptop.


Hello Chinocutlvarroz,

In the thread below, reinstalling Armoury Crate solved the 4151 error.

Solved: I can't update device & component #ROG STRIX SCOPE... - Republic of Gamers Forum - 939275 (a...

Have you tried using the Armoury Crate uninstall tool and reinstalling?