Showing results for 
Search instead for 
Did you mean: 

asus rog strix scope rx tkl wireless slow charging

Level 9

I got my keyboard yesterday and it's battery was %51. I charged it like 4 hours (2 hours with my phone charger, 2 hours with laptop via original cable). But it went up to %81. In armoury software it shows fully charged battery image but says %81 charged. I've been playing like 30mins, and i checked the battery it shows %82? Is it normal that with 4 hours charges %30 ?



All right,

You can let the cable and dongle connected with the switch set to wired mode. 

When you deleted Armoury Crate, did you use the Armoury Crate uninstall tool?

If not, you'll want to use it and is what I'll suggest next.

In the link below, select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, install version (first download), then head to the update center and check for updates.

 Let me know how it goes after trying this.

No i didnt use uninstaller. Now im doing as you told.

Hi Nate, I recently purchased the ROG Strix Scope NX Wireless Deluxe. I faced the same issue, but mine isn't charging at all. I followed the step you proposed but it still didn't work. I installed and uninstalled the Armoury Crate a few times and still facing the same issue. 

Hello isukandaru

When you uninstalled Armoury Crate did you use the uninstall tool? If not, click the link below and click show all in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, install Armoury Crate version (first download), then go to the update center and check for updates.

To update your ROG Strix Scope RX TKL Wireless Deluxe...

1) Connect the usb-c cable to your keyboard, connect the other end to a pc usb port.

2) Set the switch on your keyboard to wired mode.

3) Connect the wireless dongle to a pc usb port.

4) Try the updates in Armoury Crate.

Does this get your keyboard charging?

You can post me a screenshot of your power page if you like.

falchion charged.png


I've followed all the solutions given in this post 3 times, uninstalled using the Uninstall Tool, and reinstalled. I even reset the connection between the keyboard and my laptop, but still didn't work. I update the software to the latest version and nothing changed. I also tried draining some % of the batter from 32% to 25% in the hope of it's charged after draining some %, but nope.

My laptop model is Asus ROG Strix G15 G513IM. I tried contacting the seller as I'm purchasing this online, they currently checking with the Asus side for this matter. Here is my screenshot though.


Thank you,

It looks like it was charging at some point, maybe it's slow because you're charging from a laptop?

Are you able to test the charging on another pc?

I've tried charging use my friend's PC, but it's still not working. Is it possible that the keyboard's battery having some issues?


I have msi gf 65 thin 10sdr. Gtx 1660ti, i5-10300H 24gb ram.

Reinstalled armoury, and sees no update.