cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Claymore II Keys no longer work

Scycs26
Level 7
The I, K and L keys of my Claymore II no longer works. It either keeps repeating these keys or nothing happens if they are pressed. It's no longer in warranty and I know I'm not the only one experiencing this. I got mine as a pre-order and one year passed already when this issue occurred. I think it's more of a firmware issue since as a gamer I seldom use I, K and L keys.

Is there a way to force update a firmware from factory settings?
1,559 Views
5 REPLIES 5

Nate152
Moderator
Hi Scycs26

Welcome to the ROG forum.

Have you installed Armoury Crate? You can update the firmware through Armoury Crate.

You can also try resetting your keyboard by pressing and holding the Fn + ESC Keys for 10-15 seconds.

Nate152 wrote:
Hi Scycs26

Welcome to the ROG forum.

Have you installed Armoury Crate? You can update the firmware through Armoury Crate.

You can also try resetting your keyboard by pressing and holding the Fn + ESC Keys for 10-15 seconds.


I did but it's still the same.

Nate152
Moderator
All right, something else to try....

In Device Manager under Mice and other pointing devices, right click on your ROG Claymore II and click uninstall.

Reboot, it will reinstall your Claymore II.

Does this get the keys working?

xfridgewizardx
Level 8

I'm having the exact same issue but I noticed that my battery is swelling after a little over a year and a half of use.  I believe that the battery swelling is causing the issues with the keys at this point since the issue has now spread to the asdf row and the qwerty row.  My Claymore II is now FUBAR.  Last time I'm getting a wireless mechanical keyboard.

Edit:  I have already uninstalled the driver from device manager and all the software things even trying it on another computer with barebones install (aka driver) and no dice.

xfridgewizardx
Level 8

UPDATE:  After further investigation, I disassembled my Claymore II and saw that the vertical connector was partially disconnected due to the swollen battery.  I removed the battery, reassembled the keyboard, plugged it into my computer utilizing the wired connection and it works!  All keys are now working without issue!

TLDR: Swollen Battery was causing the issues with keys functioning.  Remove battery and keyboard still works!  Granted, this fix does remove the purpose of it being wireless.  I'm sure there are replacement batteries that can be purchased somewhere.

Hope this helps anyone who has these issues.

Edit: found battery model and you can purchase it.

Model: c11p1707

https://www.batteryclub.org/Goods/ECN11901_TE-C11P1707-Asus-Battery.html