Showing results for 
Search instead for 
Did you mean: 

Asus Rog Claymore II battery charge and discharge issue (Solved)

Level 9

I'm having some battery issues that after the lastest firmware, before the update it was working fine. i'll explain:

- im using usbc to usba (3.2) from the back io (asus rog b450-e)
- keyboard firmware: 20.12.01 / 1.00.14 / 1.00.12

When charging it stops incrementing percetage in armoury crate, says "charging" but it keeps randomly stuck at any % until i replug it againg. Same with the keyboard battery level indicator. I tried to drain the battery till 1%, then charging and got stuck at 11% and 90% until i replug the cable.

Once is fully charged it quickly discharges in a few minutes to 90%, it gets stuck a few hours at this point, then drop quickly to 86%. if i recharge again from this point it does quickly but once i unplug the cable, again drops quickly to 90% and 86%. From 86% to 16% seems to be just fine, but at 16% it gets stuck again for a period and then starts dropping normally again.

I did this process 3 times and seems to do the same every time.

i'd like to know is someone is having a similar issue after the lastest firmware or is a faulty battery before make a RMA, but as i metion before, it appeared since the lastest firmware.



Level 7

I am having teh same issue, installed the altest firmware and still the same thing... charges to 100% and as soon as i disconnect it, it drops to 81%


Level 7

asus ROG claymore ii 2023 - still unsolved.

stuck at 67% even with the latest update.