Showing results for 
Search instead for 
Did you mean: 

ASUS ROG AZOTH - FIrmware update - Encountered error trying to identify firmware error

Level 8

Just received the Asus Azoth and I can't update the firmware. Fully up to date Armoury Crate. I have the keyboard connected directly via USB, and in USB mode. I've also connected the dongle. Once I click update, I get the error "Encountered error trying to identify firmware version. Please reconnect device and click "check for updates" and try again. I've fully uninstalled armoury crate and reinstalled. Same error. Removed the Azoth driver from device manager and rebooted. After the driver re-installed, I tried the update again and it failed with the same message...

Installed Armoury Crate on a different computer and am getting the same error message. For reference, the keyboard is on version 3.00.21 and it's showing 3.00.24 as available. 

How do you get this properly updated???? And no, I will not re-install Windows to get a keyboard's firmware updated...



Mackands - Good to hear you got your ROG Azoth updated.

Since you started another thread about the login error, I replied there.

Damo2891 - Don't give up just yet, try updating your ROG Azoth again.

Level 7

I posted this in another thread as well regarding firmware updating:

I also had the same issue so I went searching for a potential config file that the keyboard might create through ArmouryCrate. Here is what worked for me. Browse to C:\ProgramData\ASUS\Framework and delete the keyboard folder; that's where I found the keyboard config.xml. You can now try again to "Check for Updates" and install. That will then rebuild the .xml file and my update went through. Hope it works for everyone else.

Primarily, like most have echoed this; this program needs to be completely rebuilt and stripped of all the bloat that it carries. This is absolutely an embarrassment to Asus to have something like this. Maybe take some advice from Corsair and iCue. May not be the best software on the market but it is far more polished than this bloatware. I simply don't understand what's going on at Asus; maybe complacency has set in. I might be returning the keyboard. I'm honestly tired of the software. I've been a pretty loyal fan of Asus for the past 2 decades but its been issue after issue. Probably the end of the line for me with Asus as far as parts are concerned. They need new leadership and vision.

Level 8

I searched through the internet and tried everything I found:

  1. Re-installing Armory Crate
  2. Testing the update on another PC (ROG G733ZM)
  3. Deleting the "keyboard" folder in "C:\ProgramData\ASUS\Framework\keyboard"
  4. Clicking the update button a total of over 50 times
  5. Unplug and replug the keyboard and the dongle over 15 times
  6. Resetting the keyboard by pressing Fn+Esc 3 times
  7. Windows 11, Armory Crate, and every driver I could think of have already updated to the latest

All of the above brought no success to my ROG Azoth firmware update.

PC Spec: i9-13900K + MSI Suprim X 4090 + ROG Z790 Hero + 32GB 6800mhz RAM.

Firmware Versions:

  • Armory Crate: v5.6.3.0
  • Windows 11: 22H2 (22621.1702)
  • GeForce Experience Driver: 531.79
  • ROG Azoth (current): v3.00.26

Please help to solve this firmware update issue with thanks.

Level 8

I also encountered the same issue; I cannot update my ROG Azoth firmware either. I have tried the following:

  1. Drivers related
    - Reinstalling Armory Crate
    - Updating all the software and firmware to the latest (including Armory Crate, Windows 11, GeForce Experience Driver, etc.)
    - Deleting the "keyboard" folder in "C:\ProgramData\ASUS\Framework\keyboard"
    - Clicking the "Check for Update" and "Update" button over 60 times
  2. Hardware related
    - Replugging the keyboard and dongle over 15 times
    - Resetting the keyboard by pressing Fn+Esc over 5 times
    - Attempt to update the firmware on another PC (a ROG laptop)
    - Strictly following the prompt

All of the above attempts did not bring me success updating the ROG Azoth keyboard firmware; the following is the firmware version for your reference:

  • Windows 11 OS Build: 22621.1702 (22H2)
  • Armory Crate: v5.6.3.0
  • BIOS Version: v.0904
  • GeForce Experience: 531.79
  • ROG Azoth Device Firmware: 3.00.26 (Date: 2023/03/28)
    (The update claims that unable to identify the firmware version but it was able to show what firmware it is running..)05_13_2023_Spec.png

Desktop Screenshot 2023.05.13 -

My PC Spec:

  • Intel Core i9-13900K
  • ROG Z790 Hero
  • MSI Suprim X 4090
  • G.Skill Trident Z5 6800mhz (2*16GB)
  • ROG G733ZM (I also tried doing the update on this ROG laptop)

Please help to resolve this firmware update issue on the ROG Azoth keyboard.

Level 7

I also have exactly the same problem as zonik526.
The specifications of the PC are almost the same.
Any plans to fix this bug?

Level 7

that is why Ive given up on this keyboard, like yeah it is nice and all that but Armoury crate dont even hold the configs that I made for lighting and all that and cant even update it, thats why I cant wait for my Zoom75 custom enthusiast keyboard to come in since that one also will feature OLED display that by the looks of it will show even more info then ROG one and it will be a lot more user friendly thru VIA and QMK, good try ASUS at doing something on sorta enthusiast level but if you cant even look after your software properly that speaks volumes not to mention I had to swap every single switch in my keyboard because at least 10 of them started double triple pressing and ghosting and ASUS dont provide enough spares to fix the problem, so not only did I spend big $$$ for keyboard it self in Australia but also had to purchase set of switches to fix more problems ! Just judging by latest videos of YouTubers that are respected seems like ASUS as company got way to comfortable in the market and they dont seem to care about customers like they use to

Level 8

I also had two updates for this keyboard, one is the firmware update; the other one is the HTML update (see my previous reply for the screenshots).

For the HTML update, you need to click spamming the update button for idk how many times in order for it to update (using "Enter" would do the trick).

For the device firmware update, read the above reply.

Spent over a month on this super stupid method but it gets the job done (at least in my situation).

Level 7

I guess this issue still isn't resolved. Just bought 2 of these keyboards for my wife and I and both getting the failed HAL update in Armoury Crate. Tried it on 2 different 2021 Zephyrus M16 laptops and a 2022 Zephyrus G14. My M16 was reformatted just a week ago, so it's a fresh Windows install. All running Win 11 22H2. Exact same error on 2 different keyboards on all 3 laptops. Fails on the HAL installation.

So, I went into C:\Program Files\ASUS\RLSDownload and saw the 3 remaining updates (HAL, HTML, and SDK). If I manually attempt to run the setup.exe file in the HAL folder, it fails due to missing dependencies in the installer package. Likely the cause of all this mess.

As a final test, I still have an older model of the G14 running Win 11. It installed and updated on that laptop with no problem. I updated the firmware to the latest version. But if I hook the keyboard up to my newer laptops, I still can't access them within Armoury Crate since it just prompts me to update, which then fails.

I give up. Returning both of these. Not wasting time with this. If it won't work on ASUS' own laptops by now, that isn't looking good.

EDIT: Just for laughs, I dug out my old custom-built desktop. Using a Gigabyte Gaming 7 mobo and a GTX1080. Keyboard works fine with it. Armoury Crate had no issued installing the updates. Seems this keyboard just hates Asus' own laptops.

Level 7

aqui esta la respuesta para laguno del os problemas a la hora de actualizar


Level 7


seems like the problem is still unsolved, same issue here with my Asus M16 (2022) and keyboard try updating it with the USB dongle, Bluetooth and USB. Can't access the keyboard settings and can't modify controls

Seems like the HAL, HTML, Device SDK can't be updated and error message 4151 keeps on showing, tryied different blogs to see if there's an answer to this issue but still out of luck,. Ill keep trying to update ferociously  like the other commenters where saying but so far no luck.

hope I can get an answer. Thank You!!