Showing results for 
Search instead for 
Did you mean: 

ASUS ROG AZOTH - FIrmware update - Encountered error trying to identify firmware error

Level 8

Just received the Asus Azoth and I can't update the firmware. Fully up to date Armoury Crate. I have the keyboard connected directly via USB, and in USB mode. I've also connected the dongle. Once I click update, I get the error "Encountered error trying to identify firmware version. Please reconnect device and click "check for updates" and try again. I've fully uninstalled armoury crate and reinstalled. Same error. Removed the Azoth driver from device manager and rebooted. After the driver re-installed, I tried the update again and it failed with the same message...

Installed Armoury Crate on a different computer and am getting the same error message. For reference, the keyboard is on version 3.00.21 and it's showing 3.00.24 as available. 

How do you get this properly updated???? And no, I will not re-install Windows to get a keyboard's firmware updated...



Hello Azerath,

1) Connect the cable to your ROG Azoth and connect it directly to a usb port on your pc.

2) Connect the wireless dongle directly to a usb port on your pc.

3) Set the wireless switch on the ROG Azoth to wired mode, this is with the switch set to the center position.

4) Try the update in Armoury Crate.

Repeating what we all already know isn't fixing this issue. I hope ASUS is throwing some real resources at this issue. Armoury Crate has been a seriously bad software for years now. I hope someone is hearing these issues. 

Level 7

In response to the reply you deleted?

Windows 11


Item Version
---- -------
Armoury Crate UWP App
ROG Live Service
Aura Service (Lighting Service) 3.06.20
Armoury Crate lite service 5.4.10
Aura Wallpaper Service Not installed
ASUS AURA Extension Card HAL
ASUS AURA Motherboard HAL
ASUS Keyboard HAL
ASUS MB Peripheral Products 1.0.40
KingstonDram 1.1.18
AURA DRAM Component 1.1.23
Patriot Viper DRAM RGB
Patriot Viper M2 SSD RGB
Universal Holtek RGB DRAM



UPDATE: Just as I was taking screenshots to post here... the **bleep** thing updated!  I did not do anything I had not done before. I had unplugged every USB except the keyboard and dongle. Removed and readded device firmware, uninstalled and reinstalled AC (for DAYS)... and now. With everything normal, just now .... as I was taking the screenshots above and was about to take the last failure message that 'aloper' had also been experiencing, it just decided to work. 




Sorry, I wasn't sure if you needed help or was just ranting, that's why I deleted my message. But, I'm glad you got to read it and it's good to hear you got your ROG Azoth updated.

The ROG Azoth is an awesome keyboard, I use the OLED display for system information to show the date and time, you can do this in Armoury Crate. 

What do you use your OLED display for?


Hah well I haven't even dug into the screen quite yet. I was too busy trying everything I could think of to update the firmware on her. Now that I'm past that, I plan to dig in. 

but yes. I was partially venting. AC has been a constant thorn over the years, and reading other reviews, I'm not alone in that thinking. I've been an ASUS fan for about 30 years. But I can't remember anytime I've seen them drop the ball this way.  

*jumps off soapbox* yep I'm excited to dig more into this keyboard. I do love the hardware 😍

Armoury Crate has come a long way over the years. I think they're doing a great job with it, I bet you'll think the same now that you're updated and can use it.

I'd like to hear your thoughts after using it for a while.

Screenshot 2023-03-28 185537.pngScreenshot 2023-03-28 185635.pngScreenshot 2023-03-29 211311.png

Screenshot 2023-03-29 212111.png


Thank you for the screenshots, I see your ROG Azoth is throwing an error with the device page.

Check for updates in Armoury Crate to see if any updates show for your ROG Azoth.

If no updates show, the next thing to try is uninstall Armoury Crate and reinstall.

In the link below select your operating system, click "Show all" in blue, the uninstall tool is the third download, use the uninstall tool to uninstall Armoury Crate.

Armoury Crate - Support (

Once uninstalled, install Armoury Crate version (first download), Armoury Crate will automatically update to, then head to the update center and check for updates.

When uninstalling/reinstalling, you can let the cable and wireless dongle connected with the switch on the the ROG Azoth set to wired mode (switch in the center position). 

How does it go after reinstalling Armoury Crate?



I’ve done that about 5x and still no result