cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Azoth Dial Stopped Working

gcleveland
Level 7

At some point, the control up/down switch stopped working. It will no longer control anything.

Anyone else have this issue? It worked for awhile.

2,444 Views
5 REPLIES 5

gcleveland
Level 7

I don't seem to be able to edit but aloper, in another thread, stated to hold down the FN+ESC for 10-15 seconds.

That reset the keyboard and now the volume does work but the oled controls still do not, etc.

Totally worked, thank you! (Pressing the FN+ESC keys on the Keyboard for 10-15 seconds)

Nate152
Moderator

Hello gcleveland,

1) Have you installed Armoury Crate and updated to version 5.4.10.0, there may be updates for your ROG Azoth as well.

2) Is windows fully updated?

3) Have you updated to the latest bios for your motherboard?

4) Do the options on the OLED display change when you press the button on the side of the control knob?

I'm having the same problem all of a sudden. None of the options for control knob works. Pushing the side changes the mode of the knob but up down and in don't work. 

 

Only customising an action works. 

WizenJJH
Level 7

Hi!! i have the same problem, i cant use the dial bc not working!! 
firmware is updated 

 

Plsss HELP ME ❤️😰