Showing results for 
Search instead for 
Did you mean: 


Level 8

Hello everybody,


I bought a Rog Azoth, the keyboard build quality is awesome 😲 but it seems i can t do anything with it to configure it with that wonderfull Armoury Crate Software.

My Setup : 

Motherboard Gygabyte Aorus X570 Elite Updated Bios F38a

CPU Ryzen 9 5900X

Ram 4x8 DDR4 Trident Neo Z

NVME Kingston Fury Renegade PCie Gen 4

Graphic card RTX 3090


First install was on my existing Windows 11. Uninstalled all previous devices drivers then installed Armoury Crate --> Keyboard tab went Error 2006. Tried to uninstall AC with Asus Tool --> Reinstall --> Error 2006 Still.

I watched forum and this was said to install on a fresh install of Windows 11. Did it even if it s unbelievable to have to reinstall an OS for keyboard software... 

Fresh Install

All drivers are up to date

No Gigabyte software or bloatware installed just plain simple drivers

Updated Nvidia drivers

Installation of Armoury Crate also done without the keyboard --> OK

Plugging in ROG Keris Mouse--> OK detected and able to setup it in AC

Plugging Rog Azoth --> AC ask for Framework Keyboard update --> Update done and restart--> Error 2006 on the Keyboard device running in circle each time i try to setup it

Reset of the keyboard (FN+ESC) --> Success but still error 2006

Second Fresh Install 

Same as above but everything plugged from start to finish with the 2 wireless dongle --> Error 2006 on the Azoth

Third Fresh Install

Same as above but plugged in USB C in wired mode --> Error 2006 on the Azoth

My App diag :

Item                       Version    
----                       -------    
Armoury Crate UWP App    
ROG Live Service     
Aura Service (Lighting Service)  3.06.20    
Armoury Crate lite service  5.4.10      
Aura Wallpaper Service     Non installée
ASUS AURA Extension Card HAL    
ASUS Keyboard HAL    
ASUS Mouse HAL       
KingstonDram               1.1.18      
AURA DRAM Component        1.1.23      
ENE RGB HAL          
PHISON HAL           
Patriot Viper DRAM RGB    
Patriot Viper M2 SSD RGB    
Universal Holtek RGB DRAM    
WD_BLACK AN1500      


If anyone found a workaroud.... because i think i ve done more than my share to try to troubleshout the problem 😅


That s crazy such a good hardware with such a whimsical software. 🙄




With what all you've tried and nothing is helping including a windows reinstall, let's verify your windows install.

1) When you reinstalled windows, you have the option to delete all partitions from the drive before the install and you want to do this. 

2) When you installed windows, there are two options.

One is to install using saved files.

One is to do a clean install, this is the one you want to do.

Have you deleted all partitions from the drive and did a clean install when installing windows?

Each reinstall i have deleted all the partitions and start from scratch. Exactly doing this :

Boot on USB Drive 

When Install prompt comes in i didn t click on Install Now but Custom

Delete all Partition on my drive 0 in order to only have a blank not partitionned drive

Select this free from any partition drive 0 and Install to let Windows create everything. 

I even tried to delete everything i had on my onedrive account in case something was messing everything in it. And to be sure, i uninstalled Onedrive before any drivers install to avoid mismatch between synced cloud files and drive files. 

Ok i tested some more on my son's comp and it works flawlessly without any struggle. 

I aim for an incompatibility related to Aorus X570 AM4 USB Controller or the MB embedded RGB controller conflict with the keyboard.

I have tried really everything on my own computer and would be curious if anyone else had a problem like mine with the same architecture. 

Level 7

I also have a Gigabyte board. X570s Aero g and i am getting the exact same issues you are and have run through all of the steps you have aswell. I think there is something up with gigabyte compatibility and this keyboard.

@Melkorsong omg ty 😂 that s the first time i m happy of seeing someone having problems.

Now i ll rest until new update to sort that out 😬

@Nate152 Maybe you could open a poll on the board for Azoth users to register there hardware and see what hardware works and what don t? IT could be a Gigabyte problem or a whole AM4 chipset one which would lead to ROG motherboard's users also having problems 😬


Ok, Melkorsong is having the same issue with their Gigabyte motherboard.

I spoke with the higher up and sent them this thread. What they want you guys to do is fill out this google form, generate a log in Armoury Crate and attach the log to the form.

To generate a log in Armoury Crate click Settings, click About tab.

Google form -

This will help them diagnose the issue and provide an update to address it.



Thank you @Nate152 , form sent here


Level 7

Very glad I found this. I'm here with a Gigabyte Aorus x670 (AM5 chipset) motherboard and a ROG Azoth keyboard, same issues. Will be generating a log and filling out the google form along with you guys. 🙂

This is the only issue I've had since rebuilding my PC. I adore this keyboard and am looking forward to an update that'll allow me to customize the OLED screen to my liking. I hope the issue will be taken seriously and resolved.