Showing results for 
Search instead for 
Did you mean: 


Level 8

Hello everybody,


I bought a Rog Azoth, the keyboard build quality is awesome 😲 but it seems i can t do anything with it to configure it with that wonderfull Armoury Crate Software.

My Setup : 

Motherboard Gygabyte Aorus X570 Elite Updated Bios F38a

CPU Ryzen 9 5900X

Ram 4x8 DDR4 Trident Neo Z

NVME Kingston Fury Renegade PCie Gen 4

Graphic card RTX 3090


First install was on my existing Windows 11. Uninstalled all previous devices drivers then installed Armoury Crate --> Keyboard tab went Error 2006. Tried to uninstall AC with Asus Tool --> Reinstall --> Error 2006 Still.

I watched forum and this was said to install on a fresh install of Windows 11. Did it even if it s unbelievable to have to reinstall an OS for keyboard software... 

Fresh Install

All drivers are up to date

No Gigabyte software or bloatware installed just plain simple drivers

Updated Nvidia drivers

Installation of Armoury Crate also done without the keyboard --> OK

Plugging in ROG Keris Mouse--> OK detected and able to setup it in AC

Plugging Rog Azoth --> AC ask for Framework Keyboard update --> Update done and restart--> Error 2006 on the Keyboard device running in circle each time i try to setup it

Reset of the keyboard (FN+ESC) --> Success but still error 2006

Second Fresh Install 

Same as above but everything plugged from start to finish with the 2 wireless dongle --> Error 2006 on the Azoth

Third Fresh Install

Same as above but plugged in USB C in wired mode --> Error 2006 on the Azoth

My App diag :

Item                       Version    
----                       -------    
Armoury Crate UWP App    
ROG Live Service     
Aura Service (Lighting Service)  3.06.20    
Armoury Crate lite service  5.4.10      
Aura Wallpaper Service     Non installée
ASUS AURA Extension Card HAL    
ASUS Keyboard HAL    
ASUS Mouse HAL       
KingstonDram               1.1.18      
AURA DRAM Component        1.1.23      
ENE RGB HAL          
PHISON HAL           
Patriot Viper DRAM RGB    
Patriot Viper M2 SSD RGB    
Universal Holtek RGB DRAM    
WD_BLACK AN1500      


If anyone found a workaroud.... because i think i ve done more than my share to try to troubleshout the problem 😅


That s crazy such a good hardware with such a whimsical software. 🙄


Uninstaller done

Reinstall done

Reboot between each.

Error 2006🙄


Ok i m in the worst case scenario after another test ... 

Tested on my son comp.



MB MSI Z690 Gaming

RAM 16Go



And the keyboard is detected..... No need to reinstall ... 

What i ve done :

Full Update

NVidia Update

Didn t plug the azoth until everything is updated

No keris mouse

Once everything was updated : i plugged it and boom...

What in my config could cause the program to act like that ? 😓 


Level 8

Ok i give up 😫

Some more tries, reinstalled without

- the coolermaster RGB controler

- Ram from my son comp with no RGB (which worked on the blessed computer)

All that was left was :

MB Aorus X570 Elite

CPU Ryzen 9 5900X

GPU RTX 3090 Zotac

NVME KingSton Renegade Fury

And still Error 2006 😭


I quit by understanding my setup is just not compatible with that keyboard 😓 erm software 😠



Thank you for trying.

You were able to get your ROG Azoth working with Armoury Crate on your son's pc?

I'm starting to get as puzzled as you are as to why you're still getting the 2006 error on your pc. The uninstall tool should have fixed it and in rare instances, reinstalling windows will 100% fix the 2006 error.

Your ROG Keris works, so I'm not sure it's a compatibility issue. 

Just a shot in the dark,  try the usb-c cable from your ROG Keris.




The cable i used with my son's PC was the same as i used with my comp. Plugged on USB 3 or USB 3.2 same results.

I finally tried Fresh Install with only microsoft drivers from windows update (not downloaded else where), just NVIDIA website drivers, same result 2006. 

I even tried with WIFI rather than wired because my son's comp was on WIFI, same result. What puzzle me also is that i can perfectly setup my rog keris with Armoury Crate, the program works flawlessly for that. But as soon as i hit the Azoth it gets to 2006. 

There may be some incompatibility between the MB's USB controller and the Azoth ? 😑


Your 2006 error really has me stumped. With everything you've tried so far, it certainly looks like a compatibility issue with your Gigabyte motherboard, especially since a windows reinstall didn't fix it, this is what puzzles me the most.

Something else to try.

Try the cable and dongle in motherboard usb ports, if no help, try the cable and dongle in case usb ports. Hopefully, this is the easy fix we're overlooking.

Your ROG Azoth should show in Device Manager under "Mice and other pointing devices".


Clever try, cause case USB tend to have a different controller but nope , still error 2006... 

I checked and i have 2 ROG AZOTH (maybe because it s wired and wireless) in my device manager and the keris mouse. Everything seems to be ok. Should i tri to manually try from there to uninstall the drivers and reboot ? 

Maybe it has something to do with the ARG MB controller added with the oled screen ? 

My setup : 


Where i plugged the dongle and usb c cable with your advice :




Thank you for the pictures, you have a nice pc.

In Device Manager under Mice and other pointing devices, mine shows only one ROG Azoth.

Since yours is showing two, this could be a possibility of the 2006 error. Try right clicking on them, uninstall both and reboot.

Fingers crossed this works, I want to see this 2006 error disappear. 

@Nate152 i tried uninstalling both and restart : same result. 

About the 2 rog azoth in device maneger :

When in wired mode, there is 2 Rog Azoth, when in wireless mode, there is only one. 

When in wired mode, clicking azoth device in AC lead me into error 2006 quickly

When in wireless mode, clicking azoth device lead me into error 2005 after a long load time.