Showing results for 
Search instead for 
Did you mean: 


Level 8

Hello everybody,


I bought a Rog Azoth, the keyboard build quality is awesome 😲 but it seems i can t do anything with it to configure it with that wonderfull Armoury Crate Software.

My Setup : 

Motherboard Gygabyte Aorus X570 Elite Updated Bios F38a

CPU Ryzen 9 5900X

Ram 4x8 DDR4 Trident Neo Z

NVME Kingston Fury Renegade PCie Gen 4

Graphic card RTX 3090


First install was on my existing Windows 11. Uninstalled all previous devices drivers then installed Armoury Crate --> Keyboard tab went Error 2006. Tried to uninstall AC with Asus Tool --> Reinstall --> Error 2006 Still.

I watched forum and this was said to install on a fresh install of Windows 11. Did it even if it s unbelievable to have to reinstall an OS for keyboard software... 

Fresh Install

All drivers are up to date

No Gigabyte software or bloatware installed just plain simple drivers

Updated Nvidia drivers

Installation of Armoury Crate also done without the keyboard --> OK

Plugging in ROG Keris Mouse--> OK detected and able to setup it in AC

Plugging Rog Azoth --> AC ask for Framework Keyboard update --> Update done and restart--> Error 2006 on the Keyboard device running in circle each time i try to setup it

Reset of the keyboard (FN+ESC) --> Success but still error 2006

Second Fresh Install 

Same as above but everything plugged from start to finish with the 2 wireless dongle --> Error 2006 on the Azoth

Third Fresh Install

Same as above but plugged in USB C in wired mode --> Error 2006 on the Azoth

My App diag :

Item                       Version    
----                       -------    
Armoury Crate UWP App    
ROG Live Service     
Aura Service (Lighting Service)  3.06.20    
Armoury Crate lite service  5.4.10      
Aura Wallpaper Service     Non installée
ASUS AURA Extension Card HAL    
ASUS Keyboard HAL    
ASUS Mouse HAL       
KingstonDram               1.1.18      
AURA DRAM Component        1.1.23      
ENE RGB HAL          
PHISON HAL           
Patriot Viper DRAM RGB    
Patriot Viper M2 SSD RGB    
Universal Holtek RGB DRAM    
WD_BLACK AN1500      


If anyone found a workaroud.... because i think i ve done more than my share to try to troubleshout the problem 😅


That s crazy such a good hardware with such a whimsical software. 🙄


Hello fellow member of Azoth / AC problems 😅


Can you post your full setup? Maybe it can also help targetting the problem. 

Level 12

Try again now.

A patch as being push for 2005/2006 error. mainly for the azoth but apply to all compatible AC keyboards



Learn, Play Enjoy!

Omg i m about to cry of joy : 




Learn, Play Enjoy!

Everything work now 🤘

Outstanding! i will send a note back asap to repot it! 

Learn, Play Enjoy!

Still can't seem to update the firmware :^(

I struggled quite a bit to update the firmware.

I clicked numerous time on Search Updates and Update Now. Triggered some time between Wireless and Wired Mode and all of a sudden it worked.🙄 


Amiddaru - Good to hear you were able to get your ROG Azoth keyboard updated.


1) Connect the cable to your ROG Azoth and a usb port on your pc.

2) Connect the wireless dongle to a usb port on your pc.

3) Set the switch on the ROG Azoth to wired mode, this is with the switch in the center position.

4) Try the update in Armoury Crate.

How does it go?



"Encountered error trying to identify the firmware version. Please reconnect the device, and click "Check for Updates" to try again." stuck in this loop, I've tried reinstalling the software numerous times