cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG AZOTH 2.4G not connecting anymore, not paired with omnireceiver

Mahailox
Level 7

After using the keyboard for about 5 days (2.4G wireless) including the whole work day today (work laptop connected via bluetooth) I turned my personal computer on today and the keyboard refused/refuses to work in 2.4G wireless mode. After checking out Armory Crate it sees both ROG Omni Receiver and ROG Azoth. When I open the Rog Omni Receiver page there are no paired devices as seen in the picture below.

Mahailox_0-1710790863493.png

I've tried reinstalling armoury crate, restarting the keyboard(fn+esc) several times with restarting my pc everytime. Both times first removing the devices from device manager. Currently after last reinstall of armoury crate and plugging in the keyboard and receiver it looks like this. With the keyboard being listed under Mice for some reason.

Mahailox_1-1710791031162.png

When trying to add the keyboard to the Omni Receiver it end with this screen and not pairing.

Mahailox_2-1710791200557.png

The keyboard still works in wired mode and bluetooth mode (using it to write this message). Only the 2.4Ghz mode does not work - keyboard "starts up", display turns on, the keyboard reacts, but never connects to the pc.

Armoury Crate shows these firmware versions

Dongle 5.00.10

ROG Azoth 4.00.8

Both devices show no updates in the "update firmware page".

Mahailox_3-1710791563584.png

 

 

364 Views
3 REPLIES 3

Mahailox
Level 7

Tried complete reinstalling and removing of everything with PC restart and this last time finally worked. The keyboard was still missing from Omni Receiver, but it finally managed to pair.

I encountered the same issue. Could you please tell me what all needs to be uninstalled?

Nate152
Moderator