cancel
Showing results for 
Search instead for 
Did you mean: 

Strix 7.1 headset just died on me

trickeh2k
Level 7
Hi,

So after little more than a year, my headset just straight up died on me today. Went to bed yesterday, turned off the computer as normal and then went to bed. This morning when I woke up and got in front of the computer, working from at home I noticed that the control hub had no leds lit up at all. Strange, unplugged and replugged to no avail. Tried four different usb ports but the only thing that happened was the led on the cups that lit up for one second before going dark again and no device was ever detected.

Up to this point, the headset has worked just fined and never showed any issues. So, are there any troubleshooting steps I can go through to possible revive the seemingly dead headset or should I just straight consider it pointless and rma it? I searched far and wide but there was no info to be found anywhere regarding the warranty of this product.
2,876 Views
2 REPLIES 2

trickeh2k
Level 7
And today, just out of random I suddenly hear the usb connected noise and get a toast message "setting up strix 7.1" and it powered up. wtf... well, I'm happy and that means I don't have to go through the rma process anymore, for now.

trickeh2k wrote:
And today, just out of random I suddenly hear the usb connected noise and get a toast message "setting up strix 7.1" and it powered up. wtf... well, I'm happy and that means I don't have to go through the rma process anymore, for now.



You didnt do anything at all?
im having the same issue right now, my headset just stopped working for some reasons!