cancel
Showing results for 
Search instead for 
Did you mean: 

Strix 7.1 failed firmware

Shieldcaller
Level 7
Hi. I bought this Strix 7.1 in late june and it was totally great for a while until I began to notice
random crackling and popping sound and it turned to worse when it began to self-restart itself, even in-game.
Even when I was not using the headset, I could see the darn thing from the corner of my eye, turn off its lights and then
light back up. Those owl eyes blinking at me in the darkness, man....
I mean, the headset was already excruciatingly against my wallet and now this B.S?
So I updated the firmware to some version and tried it. Didn't work, and put the stupid gimmick on the shelf
and back to my other pair of headset. When I had enough of those(caused my head to get too warm), I wanted to switch back
to the Strix 7.1 again. Day ruined quickly when reminded of the popping sound.
So I tried the next firmware, but THIS time, there were none but the beta firmwares.
Right, that would be okay unless the lazy description told me to install the two beta firmwares simultaneously.
I quote one of them:
"Please update the MCU &DSP FW (MCU Ver.1.5, DSP Ver.1.2.) at the same time."
At the same time? What? .... That is the opposite of user friendly If I may say so.
Whatever I said. I trust ASUS with my life, I said. I'd hand them my moonies for a cartoon of prune juice, i said and
when it told me to unplug the usb cable to restart it, kaboom, the frigging thing just stopped working.
(actually never said kaboom. It said nothing. hurr durr)
The USB station's lights vanished like my hope in ASUS and Windows told me it couldn't recognize the headset.
I can't uninstall any drivers and I can't just unplug and re plug the USB. (tried it. Lots'o'times)
Can't even plug only the headset itself into the PC because some lunatic thought it was funny to give the
headset cable a HDMI. UGH.
I goofed the darn thing up. Now how do I ungoof it?
Sry if there's another thread of this, but believe me, I tried google.
-
TL;DR my wonderful, unbreakable, fancy headset from Asus failed its firmware and now it won't talk to me.
27,139 Views
17 REPLIES 17

rmcco74
Level 7
Just thought I'd throw it out there that I'm experiencing the exact same thing, I have tried reflashing firmware etc. "at the same time" multiple times with the same results - my headset still "restarts" and I lose sound for a few seconds. I too am very unimpressed especially considering the amount of money virtually wasted on this thing. I hope ASUS will respond to us now that the OP and I are not the only ones who have wasted hundreds of dollars on a useless headset. ASUS - can you please advise whether we should return our headsets under warranty? Also - I work in IT and have tried countless things to fix this issue, like removing all of my USB devices, uninstalling the Strix 7.1 drivers and so on but I am still experiencing this issue. Thank you.

Mine is doing the same, with regards to restarts, absolutely shocking considering the price of these.

Well Asus any response

Just thought I'd let you know I got the reboots to stop after doing some PC maintenance. I'm not sure what got it working but I updated my motherboard BIOS and GPU BIOS and cleared CMOS. My RAM clock timing was also out. I then went to Device Manager>View>Show hidden devices and then uninstalled the Strix 7.1 mic driver and speaker driver from the Audio inputs and outputs section and then also the Strix 7.1 driver from the Sound, video and game controllers section (making sure to delete any duplicate installs). Then I replugged the device by unplugging the USB cable from the headset controller and plugging it back in and I have not had issues since, except the mic is really crap and I will be returning it to the store for that problem.

I doen't have duplicated drivers so i'm not sure it will work. Having the same problem, unpluging it one or two time seem to do the job for a limited time. And by the way the ENC seem to do nothing, activated or not, i don't ear a difference.

Yimimura wrote:
I doen't have duplicated drivers so i'm not sure it will work. Having the same problem, unpluging it one or two time seem to do the job for a limited time. And by the way the ENC seem to do nothing, activated or not, i don't ear a difference.


I just remembered I also cleared CMOS and have added that to the list. Please let us know how you go as I want to make sure anyone else experiencing this problem can get it fixed too! 🙂

i also cannot get my headset to work at all, im reviving this thread, my headset currently showes me the red lights, refuses to download the driver for it, its a brick. i have no audio and im at a loss.

asus suport was useless and refused to RMA, it crackles, resets, pops, squeels, its a mess, i cant update the firmwares.

to say the least im pissed and im frustrated.

someone help us out!

rmcco74 wrote:
I just remembered I also cleared CMOS and have added that to the list. Please let us know how you go as I want to make sure anyone else experiencing this problem can get it fixed too! 🙂


Well i don't wan't to clear CMOS only for my headset :s

Yimimura wrote:
Well i don't wan't to clear CMOS only for my headset :s


Ok I have had enough, this problem has come back to haunt me and I am very annoyed. I want my headset fixed before my warranty expires and I am not spending a cent on shipping and handling that's for sure. This is outrageous on behalf of ASUS. There are 3 threads open about this issue with several customers also claiming to be having the same issues and ASUS have not even responded. ASUS, do you even check your own forums and if not, perhaps you will enjoy seeing this posted all over reddit - your customer service staff are more likely to see it there as they certainly aren't doing their job.

rmcco74 wrote:
ASUS, do you even check your own forums and if not, perhaps you will enjoy seeing this posted all over reddit - your customer service staff are more likely to see it there as they certainly aren't doing their job.


Please do it, and put the link here. We need an answer, it make some game unplayable, when the headset reload, it stop the sound and sometime crash the game (fallout 4 for the exemple).