cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Flow X13 (2023) GV302XU does not detect ROG Cetra II Core

HAM-MAN1010
Level 7

System: Windows 11 Home

GPU: RTX 4050 Laptop, Radeon 780M

CPU: AMD Ryzen 9 7940HS

- I've got a new ROG Cetra II Core and plug it into the Flow X13 and the system does not show the device. I have tried many solutions on updating, roll back and delete the driver (Realtek Audio and other sound drivers), does not fix this problem. 

- I've tested on my PC (ROG Strix Z690-A Wi-Fi DDR4 motherboard) and the headphone worked well. 

- I've tried my wireless headset that uses the USB-A port and also worked well, also I plug in my ROG Raikiri Pro to the USB-A port the Raikiri Pro does work as normal but when I plug ROG Cetra II Core it does not detect the earphone.

I have all the updates to the latest version from Windows 11 and Armoury Crate.

I have checked the 3.5mm is plug in.

 

416 Views
7 REPLIES 7

HAM-MAN1010
Level 7

I found out the problem is ROG Cetra II Core uses digital signal, and the driver only recognise analog signal. I need a driver that can turns my 3.5mm audio jack from digital signal to analog signal. 

Hi @HAM-MAN1010 ,

based on your issue, have you tried removing the audio driver first and then reinstalling it? 

The ROG Flow X13 supports a 1x 3.5mm combo audio jack, while the 3.5mm jack of the ROG Cetra II Core is also compatible with devices such as PC, laptop, smartphone, ROG Phone 5, PlayStation 5, Xbox Series X/S, and Nintendo Switch. 

After confirmation by the backend team, it has been verified that the ROG Cetra II Core uses a standard 3.5mm connection, which carries analog signals. Also, the headphone did not support Armoury Crate software. Therefore, upon connecting the headset device, the system will display your device as "Headphones (Sound Card_ Audio)". Please be aware of this. Thank you.

Hello, I have tried unstall and then install the audio driver and it still not recognising my ROG Cetra II Core.

I found out that the 3.5mm audio jack shows not boot up because of some error.06c89fb4-3c53-4f4c-976a-d335906f50da.png

屏幕截图 2024-03-20 004528.png

Hi @HAM-MAN1010 ,

as mentioned earlier, the ROG Cetra II Core is analog, so the headphone name will not be displayed in the system. 

Instead, it will show as "Sound Card_audio" under the sound device. Have you connected the headphones, and no audio device appears at all? 

If you wish for the system to display the headphone name device, we recommend purchasing a digital version of headphones. 

Thank you.

Hello, I’ve checked there is no “Sound Card_Audio” appear under the sound device. And there is no sound came out from the earphone at all.

HAM-MAN1010
Level 7

14/4/2024 update, I have tried many solutions, includes 3 times windows reinstallations does not fix this problem.