Showing results for 
Search instead for 
Did you mean: 

ROG Delta S Wireless Firmware update Failed

Level 7

I've been trying to update my Device firmware to Version but it keeps error out. I've been trying to update thousand times but still unsuccessful. How do I resolve this? I'm using ASUS TUF gaming F15 laptop.



Hello Lizzaminel

1) Try using the usb-c to usb-a adapter cable for the wireless dongle, connect the cable to a usb port on your laptop.

2) Set the switch on the headset to 2.4GHz wireless mode.

3) Try the update in Armoury Crate.

Does this get your ROG Delta S Wireless to update?


Same problem. Try everything on win10 and also win11, another computer etc... A cannot use the device from the last firmware update, cannot update. 

Armoury create is  up to date.Maybe the firmware is wrong? 


Level 8

Hi @Nate152, I also get the same error. my computer runs windows 11. tried several times, wiress dongle and cable connected to my computer but still not working. any advise?


Hey guys,

Disregard my above post as I told you wrong.

With the cable connected to your headset and pc, and with the wireless dongle connected to a usb-c port, set the wireless switch to wired/off, then try the update in Armoury Crate.

If this doesn't help, use the Armoury Crate uninstall tool and reinstall Armoury Crate.

In the link below select your operating system, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, install Armoury Crate version (first download), then head to the update center and check for updates.

How does it go after trying this?



I follow all your  steps , but no difference. When i installing the firmware about 15 sec later the device restart automatically(saying "PC mode") then i get the error. If i turn off the device before the update, i get the same error during install.

Struggeling for months, i will take back the store i bought to get my money back.


I got same problem to but i think i solved it  all by myself Asus didnt even help me with (reinstalling armory create) . Try doing this;

get both usb C dongle and usb A dongle (both of them came with headphones) and plug both of them seperetly if u dont have usb C port  just plug both of them together and  dont forget to connect usb C cable to connect to headphones and computer and then try to update.

First i tried  with headpones turned off and if it didnt work switch it to wireless mode and press the button (pause play button and skip songs ) just press it 1 time and after that i downloaded the firmware

First  i tried with headphones turned off

Level 8

I have found a solution. You can now download a  Headset Pairing Tool for the ROG Delta S Wireless on the official website support page

Finally! Thank You.  This Headset Pairing Tool  works. I waiting for 4 months the fix from asus. Thanks the link PolarBread

Hello, may I ask how did it work for you?

My device, like many others, still works fine in Bluetooth mode. Yet, the 2.4 dongle has failed to connect. When the dongle is plugged in and I switch the device to 2.4 mode, the blue LED light keeps flashing. When I plug the dongle (both with and without the provided adapter) into my computer (tried pc and laptop), it doesn't show up on the armoury crate or the pairing tool. However, when I connect the device using the type-c to type-a cable included in the box, switch to 2.4 mode, and keep pressing the button on the device, 10-15 seconds later it beeps 3 times and says "PC Mode", then the device will show up on the pairing tool (still not on AC). Yet, in the pairing tool, the "pair" button is still grey and unable to be clicked.

Long story short, when there just the dongle in the pc, no matter what I do, the device does not show up on the pairing tool. 😞