Showing results for 
Search instead for 
Did you mean: 

ROG Delta S Wireless bricked?

Level 8

So I bought ROG Delta S wireless headset couple of months ago, it was working fine until today, I turned the headset on an it doesn't want to connect to the wireless adapter (2.4ghz) nor bluetooth, I tried restarting my PC, plugging the headset in and checking for updates, didn't do anything. Another thing that I notice is whenever I turn the headset on, it just makes a "beep" sound and doesn't say anything, usually it makes that same "beep" sound and then says "connected" whether it is a bluetooth connection or 2.4ghz. I tried connecting it to my phone through bluetooth that didn't work either. Another thing is whenever I connect it with a usb cable it says "PC mode" which doesn't do anything. Every time I try to turn it on 2.4ghz mode the light just keeps blinking blue and that's it, doesn't go anywhere from that. So my question is, is there a way I can reset the headset on its own or do I have a problem that I can't fix without sending it back to the store?


Level 8

I have the same issue too ,can't updated firmware by Armoury crate .

2.4 Ghz mode didn't work , but BT mode is fine 

The last update was on my new computer is Windows 11 OS ,headset was working fine.

until today ,when I use my old computer is Windows 10 OS ,2.4 Ghz mode fail to connect and can't install old firmware.

Bug FW version : 

I haven't found any solutions on a software side to fix it, so I ended up bringing it back to the store, hopefully the warranty covers that problem.


Yes well that would have been useful 3 months ago, since I had to return the headset back to the store... Its very interesting how you have to be connected to both 2.4GHz and USB at the same time to even update it, while the headset is bricked and cant be connected to the 2.4GHz thus making the new firmware useless since it cant be installed on the headset in the first place... Anyways, I'll make sure to get a new headset from a brand that makes sure their firmware actually works before forcing the update on their users and as a result bricking their hardware.