cancel
Showing results for 
Search instead for 
Did you mean: 

ROG DELTA S stopped working after latest round of ArmouryCrate update

varun_c
Level 9
Hi,

My ROG DELTA S headset stopped working after latest round of AC update. I tried uninstalling the AC using uninstall tool and reinstalled it again . But still the same problem persists.

The headset is displayed in AC but I see the following error.

95521

Below is the screenshot from the update section of AC ..

95522


I am able to control the RGB on the headset using AuraSync ... In the device manager I am only seeing ROG DELTA S microphone and also no option to select ROG DELTA S as output device in the windows taskbar ...

I tried connecting the device to different USB Ports on the PC and also the USB ports on throne Qi but still the same.

The headphone is working without any issues on a MAC book air (immediately after plugging in) and also on my Samsung Galaxy S20 Phone and Samsung Galaxy Tab S8.

Can someone please help me out . It looks like the latest round of updates in AC broke something to make the headset stop working , as i see its not getting detected as a sound o/p device itself .


Thanks
Varun
8,297 Views
23 REPLIES 23

Nate152
Moderator
Hello varun_c

You have an update or something on the features tab that is showing a red icon. It looks like the Animatrix could use an update as it's showing an older version.

Are you able to update the Animatrix or anything in the features tab?

95524

Nate152 wrote:
Hello varun_c

You have an update or something on the features tab that is showing a red icon. It looks like the Animatrix could use an update as it's showing an older version.

Are you able to update the Animatrix or anything in the features tab?

95524



Mine is not the animate version of Delta S . So this doesn't apply to my headset. Thanks for pitching though. I went to the features tab but it was for the animate stuff.. not applicable to my delta s .

Nate152
Moderator
Thank you for clarifying.


1) Disconnect your ROG Delta S from your pc.

2) Use the uninstall tool to uninstall Armoury Crate.

3) Install Armoury Crate version 3.2.3.0 and fully update Armoury Crate to version 5.3.4.0.

4) Connect your ROG Delta S headset and check for updates in the Armoury Crate update center.

Maybe trying it in this order will get it recognized.

Nate152 wrote:
Thank you for clarifying.


1) Disconnect your ROG Delta S from your pc.

2) Use the uninstall tool to uninstall Armoury Crate.

3) Install Armoury Crate version 3.2.3.0 and fully update Armoury Crate to version 5.3.4.0.

4) Connect your ROG Delta S headset and check for updates in the Armoury Crate update center.

Maybe trying it in this order will get it recognized.




Where do I get 3.2.3.0 version ?

varun_c
Level 9
tried everything still doesn't work...


Strange thing is the ROG DELTA S headphone is missing in device manager of my desktop where its not working ...

95536


The headset is working perfectly fine immediately after plugging in to a different windows 11 laptop (No armoury crate) and I can see the headphone listed in the device manager.

95538

Nate152
Moderator
In Device Manager, right click on all headphones and microphones and click uninstall, restart your pc and see if your ROG Delta S is recognized.

It should be showing in windows sound settings too.

95542

95543

varun_c
Level 9
Tried it still the same . I don't see it in either of the places.

Nate152
Moderator
Are you using any other audio devices? Try disconnecting all other audio devices.

Disconnect the ROG Throne Qi as well.

Use the USB-C to USB-A adapter cable and connect to a motherboard USB port, this is how I'm using mine.

I see your device list is completely empty in Armoury Crate, are your other ROG Devices showing in Armoury Crate and are they accessible?

Let me know if using the adapter cable connected to a motherboard usb port worked.

Thank you.