Showing results for 
Search instead for 
Did you mean: 

ROG Delta S Animate High pitch mic noise with firmware 1040

Level 9

Well, since in Armoury Crate my Voice Gate and Perfect Voice slider seems backward for me and I'm the only one that seems to notice it,  I wanted to be sure that my ROG Delta S Animate was not deffective so I order a second one.

Out of the box, Voice Gate and Perfect Voice was still not working properly. I tested the mic and it was good, way better that my current headset, without any noise.

But well, as soon as I update the headset to 1040, an high pitch noise appeard when I was listening to my mic, the exact same high pitch noise I've noticed on my previous headset. That high pitch noise just kill the quality of this mic and I have to use third party software to get rid of it, because using the Noise Gate on Armoury Crate just doesn't work...

Can you please take a look at this problem and at least revert back the mic to his out of the box quality? And check those Perfect Voice/Noise Gate slider that doesn't work as intended?

- Use an updated Delta S Animate without Perfect Voice/Noise Gate/AI Noise Cancelation/ and remove your EQ
- Click on "listen to this device" in Armoury Crate
-Notice the high pitch noise really noticeable at high volume (70-100 on Windows)

-Use a brand new Delta S Animate  without Perfect Voice/Noise Gate/AI Noise Cancelation/ and remove your EQ
- Click on "listen to this device" in Armoury Crate
-Notice that this high pitch noise isn't there even at 100 volume



Hello PWNED_

I haven't experienced any high pitched noise but, it does seem that the Perfect Voice and Noise Gate are reversed.

Doing some testing, my mic picks up my pc in the background.

Selecting Perfect Voice blocks the background noise.

Selecting Noise Gate makes it a little louder.

AI Noise-Cancellation seems to working as intended.





Hi Nate152 and thanks for the answer,

I can't seems to hear that high pitch static noise i'm referring to in your video capture, but a thing that I'm sure is it's not a hardware issue since the new headset did not do this noise out of the box, and the noise apears during the firmware update while I had the headset on my head and "listen to the device" active.

I'm sorry I should have noted somewhere the native firmware of the headset before updating it but I really thought it was hardware issue at first so I went ahead and updated it.

I have since tried to test both headset on an laptop, with and without bieng plugged to a wall, and they still does it. It also seems that this high pitch noise is "stronger/more noisy" when the animate is set to "mic animation" by toggling the switch all the way to the top on the headset.

I'll try to post a video capture as soon as possible.

is there anyway to revert back the firmware from the headset?

Level 9

Here it is, I hope it's clear enough, at least in my end I can definitely hear the high pitch noise that appeared right after the update 



Yep, I can hear it, sounds like a high pitched buzz.

I'm not sure what would be causing it, here are my versions in Armoury Crate.

Do yours match?

Delta S Animate.png



Yep, same version for  everything.

Sans titre.jpg

Is there really no way to downgrade a firmware on this headset if anything goes wrong?

There is this file in the support called "ROG Delta S Animate Rescue FW" for the "ESS" that some had earlier. It seems to be a way to flash the firmware but I don't know what firmware this really rollback to so I don't know if it will really help in anything here.

I'm possitive that this appears right after the 1040 firmware update, my audio cut out during the update then this buzz appears. I've also tested 3 different microphone (two form delta S Animate, one from a delta core) and it still does the same thing.

I could go ahead and order yet an other brand new headset, just to be more that positive it is the firmware, but it's really not reasonable and something that the actual Asus support should veriffy. 

The only way I know to update is with Armoury Crate and there is no rolling back of any firmware that I know of. 

Do you have any other audio drivers installed?

Since you can't pinpoint it, I would try using the Armoury Crate uninstall tool and reinstalling version

Armoury Crate - Support (

If you've already done that and it didn't help, I'll leave this up to you and won't tell you to do it, but I'd try a fresh windows install with Armoury Crate installed only. Since I don't have the high pitch buzz, it's possible some program is interfering with it.

I do find it strange you only get the high pitched buzz after the 1040 update.





Level 9

Yesterday I tried to install the realtek audio driver for my motherboard (x570 Dark Hero) but it didn't do anything. I tend to not use any realtek driver since A-Volute service that is shipped with them tend to break games, and Sonic Studio III and Sonic Radar just break Xbox Xcloud streaming (the stream become black if the window is reajusted or going to windowed to fullscreen). As I don't use onboard audio I just don't need those driver that tend to be more porblematic than anything in my use case.

Also did a reinstall of Armoury Crate just to be safe but no, the problem still remain.

As for a reinstall of windows, I'm really not in a mood to do this yet again at the momment but know that on my previous Delta S Animate I had this buzz in the mic even after a fresh reinstall (I always thought it was just the mic quality at first). The fact that I've also tested both headset on 3 differrent computer (a desktop and a laptop on W10 and my main desktop on W11) without any common software beteween them that I could think of that would interfere with audio, lead me to think it's not any of my computers.

The only think that I'm sure of is that this appears after the 1040 firmware update and the only thing to confirm it would be to have a way to revert it back to a previous/original firmware.


Edit: I should also have noted that the 2 computers on windows 10 have no Armoury Crate installed at all. I just plugged the headset and tested it as is.

Edit 2: Also tested it on a Samsung Tab S7, same exact static noise


Level 9

Sorry for the double post but something got me intrigued, I've mentioned earlier in a reply that when I put the switch to "mic animation" on the headset, that this static noise get louder, I also just noticed that the firmware 1040 is reffering to the LED firmware aka the Anime Matrix.

So I did some more test, changing the animation of the headset :

-When I switch animation, the static noise get louder than stop after the animation is loaded
- Text animation or any kind of custom animation make this static noise even louder and choppier, like it is reacting to the animation.
-And the mic animation (not tested in the video capure) make also loud (probably the loudest) static noise as usual.

So I guess the Anime Matrix firmware here is only the problem of this headset?

I'm using one of the default presets for the Anime Matrix.

I'll try adding a gif and see if I get the high pitched buzz.

Edit - I tried a gif in the Anime Matrix and I'm unable to replicate the high pitched buzz.