Showing results for 
Search instead for 
Did you mean: 

ROG DELTA Headset lights wont work

Level 7

It has been two months since I bought my headset and it is working just fine and great.

last week I closed switched the rgb lights off and today when I turned it on the lights did not light up, I opened the armory crate and updated the drives and the firmware of the headset but it kept telling me to switch the lights on even though it is switched on 


in all honestly I am really upset that it work, i looked at old forums that said downloading the ENEFWupdatetool, Delta0039, USB Firmware or even the Delta USB Audio Rescue FW helped but it did not work at all.

the Delta USB Audio Rescue FW detected the headset and "downloaded" the firmware but it didn't do anything, the rest cannot even detect the headset I am guessing because they are old versions and might not be compatible with windows 11.

I really nee help with this issue I had never had any problems with the headset so for it to not light up the lights on short time usage is really upsetting. 


also I tried uninstalling the crate application and restarted the PC but nothing worked.




Level 7

I the windows search open "Device Manager" > Find "ROG DELTA" under the "Other devices" right click and update.

I did try doing that but still did not work.