Showing results for 
Search instead for 
Did you mean: 

ROG Centurion - No sound from center speakers

Level 7
Hi, I've had my ROG Centurion for 4 months now and they worked fine up until a week ago when the center speakers stopped producing sound even though they are not muted on Sonic Studio, the USB audio station or via speaker levels in Properties.

I configured the speaker setup in Playback Devices but when I do a test to check the sounds by clicking on the speakers in the 7.1 setup, everything but the center speakers work. I should add that when I do another test, like the gunfire one in Sonic Radar while having Sonic Studio open, the sound levels on Sonic Studio indicate that the center speakers are processing but no actual sound can be heard. Front, side and sub-woofer speakers all work though.

I've uninstalled the Centurion via device manager and reinstalled the drivers multiple times but still no luck.

Lastly, I can emulate center speaker sound by using a reverb option on Sonic Studio like Stadium but even with that on, the center volume levels are still very low and it's just a workaround, not a real fix. I also don't know if this helps but this only started happening after I took the Steam hardware survey.

Any help will be greatly appreciated, thanks.

Level 12
Sorry that you didn't get a reply for this. Currently there are only reports regarding to issues with rear or sub but no one has mentioned center speakers. If you confirmed that center speakers are not working at all in any channel setup then likely you may have a defective headset and may require RMA replacement.

I have a similar issue. The left earcup does not work unless I angle the hdmi cable at a certain angle. It appears to be a loose cable. Unfortunately the small store I purchased from has gone bust during covid and I now can't take it back. Sadly ASUS customer support has said that his is my only option and I'm now stuck - fool me for not registering :S
I've taken the cup apart so that I can look inside and it's caused by movement when on the inside of the rubber joint, just as the cables are soldered to the board.
I believe that it's a design fault and it's really disappointing, especially from a reputable seller like ASUS. I've been looking on Ebay for a replacement headset and I must say that I've seen two in the last week that have exactly the same fault!
I'm going to try to get this one fixed as I can't deny that the sound quality is, in my opinion the best on the market but I'll never trust another ASUS product after this. Unfortunately, I'd not recommend the headset to friends either. It's too much to lose after a year or two of use.

I'm going to continue this thread and recommend anyone I find to contribute. I'm in UK and I'm going to look at consumer rights, particularly as to whether or not this can be raised as a potential design fault. If you know anyone else with this issue then please get them to comment here: