cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Centurion 7.1 not working

bugwak04
Level 7
I have an issue with my ROG Centurion 7.1 Gaming Headset the USB won't detect it. no light in the ROG controller box. fyi. just reformated now won't detect my ROG centurion


94714
94713
3,838 Views
12 REPLIES 12

xeromist
Moderator
Are other things recognized plugged into that USB-C port? Do you have a USB-A to USB-C adapter to try connecting the centurion to a different port?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
Are other things recognized plugged into that USB-C port? Do you have a USB-A to USB-C adapter to try connecting the centurion to a different port?


When I unplug and plug it back the Headset lights on just a second then suddenly turns off

bugwak04 wrote:
When I unplug and plug it back the Headset lights on just a second then suddenly turns off


No, I mean have you tried other devices? Not the headset?

And try the headset with a *different* USB port.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
No, I mean have you tried other devices? Not the headset?

And try the headset with a *different* USB port.


I've already tried to do what you want me to do. However, it seems that none of those you mentioned works. I also tried to plug a different headset, Razer, to be precise. It worked, but when I plug my ROG headset again, it doesn't work. Perhaps you can recommend another solution. Because I've been trying to fix this thing for about a week already.

xeromist
Moderator
OK, thank you for confirming. To me it sounds like perhaps there is a problem with the driver. Can you try to reinstall the driver from the support page?
https://rog.asus.com/us/headsets-audio/headsets/usb-headsets/rog-centurion-model/helpdesk_download/

Be aware that there does not appear to be a driver for Windows 11. So if you are using Windows 11 you can try the Windows 10 driver but it might not work properly.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

MasterC
Community Admin
Community Admin
Did you plug in both USB Type-A connectors to the PC? (One is data, other is supplementary power). From your picture, the second connector isn't connected. Also note that this product is not supported by Armoury Crate.
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

hola a mÃ* me está pasando algo similar con mis rog centurion ..! cuando apago el equipo y no pasa más corriente al encender mi pc enciende todo perfecto pero mis rog centurion no prenden .! compre un cable pensando que era ese el problema ..pero no seguÃ*a haciendo lo mismo ..! después de un tiempo me di cuenta que prendÃ*an dejando que pase un rato y encendÃ*an ..podrá se la estación o un de controladores !! la verdad no sé qué podrá ser .! si alguno lo pasa los mismo desde ya se agradece alguna información .!! saludos

i have the same issue was working fine till yesterday evening i was running 22h2 Windows 11 since release no issue with headphones now nothing this is very annoying for a £250.00 set of headphones as they cost

why are Asus no longer supporting into windows 11 onwards as headphone technology hasn't upgraded or changed in over 20 years of computing.

the advent of USB sound isn't something new either been a connection type for headphones on all platforms for years also.

ASUS sort your **** out and provide an upgrade that works and support please.

Nate152
Moderator
Hello Ultrasonix

Sorry to hear you're having issues with your ROG Centurion 7.1 headset.

From the ASUS Support Center, there is a firmware update to improve the "no device found" problem.

Select your operating system, then click on BIOS & FIRMWARE.

https://rog.asus.com/us/headsets-audio/headsets/usb-headsets/rog-centurion-model/helpdesk_bios/