Showing results for 
Search instead for 
Did you mean: 

ROG Centurion 7.1, dead audio station after firmware upgrade?

Level 7
Hey, just a question regarding my Rog Centurion headset. I updated to latest firmware the other day, and everything worked fine for a couple days. After turning off my pc for maybe 12 hours (something I usually never do, they tend to stay on 24/7) the headset is no longer recognised by windows. In device manager it says
Unknown USB device (Port reset failed)
and under device status I have the following message:
windows has stopped this device because it has reported problems (code 43) 
A USB port reset request failed.

Not unfamiliar messages, have encountered them a few times through the years, but none of the usual troubleshooting tricks have worked so far.

When I plug in the headset, no matter if its through a hub or in any of the ports of the mainbord (ASUS ROG MAXIMUS VIII HERO ALPHA, BIOS 3703) I get no sign of life on the audio station. No lights turning on, not even a blink, but the lights on the headset itself lights up for a second then disappear as well.

So in summary, after updating firmware on the audio station everything worked fine, also after a reboot, but turning the PC off for a few hours ended with the headset saying goodbye.

So is this a case of RMA (closing in on 2 years since I bought them) or is there a way to reflash the firmware, either downgrade, flash the same or the modified one from the sticky in this forum, when the pc, and then also the firmware tool, will not recognise the headset as being connected?
Or any other ideas if someone have encountered the same issue and managed to fix it?

I send a mail to the support. They said if it work on an other PC it's not the problem from the headphone.

I told them I could be an issue from the hub and the firmware but they don't care at all.

I change nothing on my computer and little by little it stop working and now it never turn on on my gaming PC.....

Answer from asus french support:
" If it's work on an other pc, it's not a problem from the headphone, so we will do nothing"
I told them it could be a firmware update, they don't care.

So I ask them to answer officially on the thread, I waiting an answer.

I really think they don't give a ****ing ****!

can i connect my asus theta 7.1 to the dac of asus centurion 7.1?


Tempted to take all my R.O.G Headsets/Mics, Gaming Mice, Keyboards, and Laptop to the trash heap. for the price we pay for this stuff and NO support ASUS/ROG you are a ****ing joke. Your Online chat is bull****... we want to ****ing talk to someone from the technical branch not be aided by a ****ing bot that knows **** all. Or read a ****ing f.a.q that doesn't relate to issues being suggested.

The Centurion 7.1 Amp is atrocious, the fact that it only wants to work when it wants to work is atrocious. Mine was working fine until my pc decided to do an ASUS Live Update on it's own accord. Guess what STOPPED WORKING!!! I've a good mind to report your company to the Fair Trading Standards Agency because what we pay for and what we get in terms of support is neither here nor there... we pay these prices expecting the best not some substandard piece of ****.

Not the first time its happened either, but why should I have to keep problem solving this ****, format my computer, roll back drivers etc etc. You've sold a substandard product and you fail to rectify it.

Level 7
Hello everybody i waited for quite some time for my forum account to be enabled. So i found a fix for it the problem is not a bios or bios chip i replaced it and reflashed same happens everything works normal till u shutdown pc after it gets cold i wont boot.Yes cold if its warm it will boot. So to the problem with me and probably to all of you since we all had same problem is with CM6210 located on side of pcb where mic switch is. Solution is to reflow the chip using flux and hot air gun. As shown on picture.If someone need more info dm me.Since i reflowed it works normaly.

Hello guys,

I reflowed the cm6210 but after some time they only turned on for a while after starting the PC. Since that moment kept getting longer until today, today.... they didn't turn on at all, so I told myself that I'm going to fix them since i realize it needs very low temperature gain to make it work.


So the only thing what i need when i turn on my PC "Make It Bun Dem" 😉


Custom build case
Asus Maximus XI Apex
Intel Core i9-9900K
G.Skill 2 x 16GB DDR4 (F4-3200C14D-32GTZ)
2 x Samsung 970 PRO 512 GB RAID 0
Samsung 860 Pro 512 GB
Gigabyte GeFrorce GTX 1080 (Asus XOC bios - no limits)
Corsair HX1200i