Showing results for 
Search instead for 
Did you mean: 

ROG Centurion 7.1 - 16bit/48khz max? What about 24bit or 32bit?

Level 7
I got an ROG Centurion hoping for a really high quality DAC based on seeing ESS9601.

I installed latest drivers and app, but Windows 10 only offers me these choices from the sound driver:
16 bit, 44100 hz (CD quality)
16 bit, 48000 hz (DVD quality)

Is there any way to get anything better? I was hoping for at least 24 bit, 96000 hz (Studio quality)
or maybe even 32 bit, 192000hz

In Windows, my driver says:
Driver Provider: A-Volute
Driver Date: 11/24/2016
Driver Version:
( If I search for anything else it always says I have the best driver installed. )

I have Sonic Studio v1.1.20
Sound Card FW v1.0.6
Control Box FW v1.3

Thanks in advance for any helpful responses here.


At the bottom right of your screen click the little arrow beside the speaker and bring up SupremeFX, you should be able to change the bit rate and sample rate in SupremeFX.

Thanks, but I don't appear to have SupremeFX. It doesn't seem to have come with the software/driver bundle I got from the Cenutrion support downloads page.

Is there another app I should be downloading from somewhere?

The ASUS ROG Centurion 7.1 USB "base station" identifies as device 0B05:1815 (VID:PID). I think I need a different driver for that device that supports/offers better than 16bit/48Khz.
Hopefully ASUS didn't put some 16bit interface chip in front of the 32bit DAC.

I go sound -> (speakers) Device Properties -> Additional device properties -> advanced

This is my working speaker device. I get 7.1 sound out of the headphones. The "Levels" tab gives me access to volume controls for all 7.1 channels.

The (test) button plays the xylophone jingle in the headset. I am sure I have the right device selected, but it just doesn't offer the bitrates/sample-rates I had expected.

I recently flashed the "control box" device with the latest beta driver, but it didn't change the options in the device properties.

I think the available rates come from this device driver:

I seem to have a different view of sound devices in my Windows 10 system properties.


Level 7
Note, I did some searching and saw people saying "Install Sonic Studio 3"... I found that and tried and it said my device is not supported.
I am NOT using motherboard audio. I have Asus Centrion USB headset, and ASUS PG32UQ monitor. If SupremeFX is just for Asus motherboard audio, I need something different for the Centurion USB device driver, since I have disabled my motherboard Realtek Audio.

( FYI, my motherboard is ASUSTeK Prime Z490-P, but I don't think that matters here.)

I tried putting the ROG Centurion on my Alienware laptop and had the same results with 16bit max.

My mistake, I thought the ROG Centurion 7.1 used the Realtek audio driver.

Are you checking here?

System, Sound, All Audio Devices, Properties