Showing results for 
Search instead for 
Did you mean: 

Replacement cable for ASUS ROG Vulcan ANC

Level 7
I bought this product (Vulcan ANC) several months ago, and had a great experience from the word go. Unfortunately, recently: My cat had a great experience playing with the detachable cable which carries the mic and speaker signals from the PC to the headset, and when I found out, the cable was already beyond repair.

I've looked fairly hard for where to buy a replacement cable, but have found nothing. I tried the ASUS hotline, and after 8 minutes of voice menus (none of which were quite what I wanted), ended up on the phone to another party (emprgroup) who only deal with replacement power cables and batteries, not audio cables.

All of the forum posts I've found along similar lines end the same way "Buy a whole new headset and use that cable" which, frankly, isn't a solution at all...

My question is: Where can I buy a replacement cable for the Vulcan ANC (preferably an exact replacement, but if no such product exists for individual sale, and equivalent that will work for both mic and speaker signal). Any help would be greatly appreciated - I've got the headset connected by a 3.5mm to 3.5mm cable now, and it's carrying sound to the headset just fine, but it renders the mic useless in its current state.

Anyone have any advice to share?

Thanks 🙂

Level 7
Yeah same thing happened to me, only it was my dog that chewed it up. It seems like common sense that ASUS should sell such a specialized cable, but they don't. Even tried looking for the past hour or so for a *3 Ring Male, to dual 2 Ring Male 3.5mm cable* and there is nothing out there.

Asus won't throw me a bone either, and my Newegg RMA is void because I'm responsible for the damage.

If anybody has any info on what to do (Besides buy a new one) we would both greatly appreciate it!

The microphone mute button on my cable broke, and im stuck now. Has anyone found a way to get a new cable? If possible, I wouldn't mind the new Asus vulcan pro wire, since i prefer that type of cable.

I too am in need of a replacement cable. Has anyone found anything that has worked yet? Thanks!

Level 12
I looked into this, hoping that we could add it to the eStore, but sadly it's sold only as a full unit with the headphones themselves. So I guess maybe eBay or Craigslist might have a few people with broken headsets that would be willing to sell the included accessories that are still in good condition.

Look at the calbles here:

They say they are mic and stereo so they might work.

I checked here which is where I go first for asus parts:

But they didn't have anything. Nice sale on 17" ROG backpack though.

If Asus doesn't want to sell a new cable could they, at least, please post the schematic so that people can build them.

Alternatively, would someone with a working cable "ring it out" and post the results - Please PLEASE.

I do know that a standard 3.5mm stereo cable with plugs at both ends will cause the audio part to work properly. In that case there is a "ring" and two "tips" one tip is L and the other R. The full Vulcan cable has three "rings" so I would assume that the third "ring" is the microphone.

Dell uses the same "TRRR" "Tip ring ring ring" on some laptops and I bought a cable that went from that to separate headphone and microphone sockets that would with the standard pink and green connectors common on headphones then I connected plug to plug from the separate connectors to the computer but no luck.

I had a similar experiment but it was with a monitor power supply. Bought the monitor in 2006 (asus pw191) and in 2010 my cat ate the cord. I call asus hq in the usa and they shipped me a new powersupply for that monitor (I live in canada and I had to pay, of course, something like 60 buck to get the cord)

Take a chance and call them

Level 7
Thanks TheStillWind - The first thing I did after googling for a replacement cable was trying to call... Machines passed me from place to place, ultimately to a nice gentleman who knew nothing about ASUS (no idea why the phone connected me there). Tried again, and after 20 minutes of being passed from machine to machine, I was finally transferred to... An engaged tone.

I have given up on a solution now and sworn of ASUS for life. Great product, but the support has been non-existent, and for the official solution I found on the day to be "Go and buy a new one" (like a good consumer) is absurd.

Best of luck to those who posted the same issue I had.

Amazon -> 6.91€