cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with ROG Theta 7.1 after Armoury Crate Update

Chrithu
Level 8

Hey guys, I did not update Armoury Crate or Headset Firmware in a long time since everything worked fine and was set up the way I liked it.

I recently started dabbling in music produktion and wanted to create a new profile for the Headset for this purpose. Upon opening armoury crate it forced me to update the software and the headset firmware.

Afterwards I am unable to select or create profiles on the device page (see first picture).
Also on the device page when I change to the "lighting" tab it displays an error message and asks to ensure that the device is switched on (second picture).

So far I tried using different USB ports and reinstalling AC numerous times.
No Solution.
Also in windows sound control panel when I test the Headset it is crackling horribly. When I watch videos sound is fine.

Any Idea how to resovlve the issue?
It clearly is a software issue with the newest AC version.
No Profile.PNG
Lighting error.PNG

292 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Chrithu
Level 8

Hey guys. Just wanted to chime back in to let you know that I found a solution to my issue.

Turns out that I actually did turn off lighting on the headset by pressing the mute button for 3 seconds. I turned it back on pressing the mute button for 3 seconds and now can create profiles again.

Hope this helps others with this issue who come here in search of a siolution.

View solution in original post

4 REPLIES 4

Chrithu
Level 8

Hey guys. Just wanted to chime back in to let you know that I found a solution to my issue.

Turns out that I actually did turn off lighting on the headset by pressing the mute button for 3 seconds. I turned it back on pressing the mute button for 3 seconds and now can create profiles again.

Hope this helps others with this issue who come here in search of a siolution.

Semajaddot
Level 7

This was driving me crazy too, until I read your post.  Thanks so much for assist!

asusjason
Level 7

Thank you.

nathanp9001
Level 7

Anybody know why I would be missing that entire audio EQ tab in mine? Just got the same headset.