Showing results for 
Search instead for 
Did you mean: 

Delta Wireless S not turning on after trying to update firmware

Level 8

Hello everyone!

After trying to update to todays latest firmware version I don't know why my PC stopped recognising my #Delta S Wireless headset. Trying to turn on either 2.4GHz or Bluetooth does not trigger the *boop* sound anymore nor does it turn on the blue light in bluetooth mod


Has this happened to someone else?


Level 8

I found a way to fix it. It seems that the installation of the Firmware didn't go all the way through. By reconnecting the USB-C antenna I got Armoury Crate to detect again that the headset required an update. After that, while having connected the headset I left it on the 2.4GHz mode and let Armoury Crate to install the Firmware update properly.

I'm sorry if I caused any inconvenience and hopefully this will serve someone else in the future.

I have the same problem, but the update is not going through no matter what.  

Level 8

Hey @Coll1sion !

Have you tried to reinstall Armoury Crate? Doing that I've been able to successfully force updates on the headset. The exact steps are the following:

  • Disconnect the antenna from the PC.
  • Uninstall Armoury Crate. (No need to restart)
  • Reinstall Armoury Crate.
  • Reconnect the antenna to the PC.
  • Check updates for your devices.
  • Update the headset.

I've also contacted support to see if they have any other way to better repair the headset, as right now I'm having this issue with the firmware each time that I leave the headset charging for a long time.

Hopefully this can help you!

Level 7

I tried but it did not work, but then I treid on laptop and the update went through. So it got fixed. I have windows 10 on PC and that might be the reason, while the laptop had windows eleven so it updated firmware fine. 


It might be helpful for someone