cancel
Showing results for 
Search instead for 
Did you mean: 

Audio optimization stopped working with latest SDK and ASUS Framework 4th of january

Mastervultanuz
Level 8

i was using my headset as always and then i opened Armoury crate to change my EQ and basically my preset and i was obliged to update my headset (ASUS ROG Delta S Eva Edition) and now every audio optimization is not working.

I was looking at the history of updates and the problem came with update of SDK and ASUS Framework from january the 4th, also idk if the driver itself on admin device was Bongiovi before?, because i was looking at it i tried to delete it and after reinstalling Armoury crate keeps installing it, anyone with any solution? I started thinking to use Firmware rescue but i think is not as bad as having a bricked headset to you use it.

EDIT

this is a temporary fix 
just download the complete  Armoury Crate | ROG México

 

MX page is newer than US version

Before everything i uninstalled the actual armoury crate, then i remove the bongivi driver from device manager, now i installed armoury full and i select only my headset, if you have more ASUS products remember that the SDK is going to be the same for all of your products in this case 2022/09/25, also you are going to have several problems with Tidal i already post about it down here and if you stream there are several audio problems, like clipping audio, but in general is a temporary fix, also this armoury crate ask for update but you can choose to don´t ask again.

3,004 Views
22 REPLIES 22

OzanElik
Level 7

The device I use is the TUF Gaming H1 Wireless headset. As you said, after the update, I couldn't switch between profiles and the sound changed a lot. I sent an e-mail to Asus Turkey and I am waiting for a return from them. Thank you also for opening the subject in this way.

Mastervultanuz
Level 8

More information about this problem, now i got in some games a window saying Failed to initialize Audio Device and they sound really bad, too much virtualization...

OzanElik
Level 7

I frequently check for updates and will let you know if a new update is available.

AthamaS
Level 8

I also have problem with my rog delta s contacted with the live chat support twice. The rog delta s on the device manager has no name on the registry/licence its just blank its supposed to be an ESS audio or something like that i believe but its not. I made the firmware update on the 04.01.2023 from the armoury crate but know after the firmware update it became something like bongiovi acoustics. Also after the update on the armoury crate no matter what i change in the armoury crate app the equalizer the virtual surround the reverb it does not make any effect on the headset nothing changes no matter what i do on the armoury crate app. I'm 100% sure the problem is not with the headset nor with the pc. I uninstalled everything with the armoury create uninstaller and made a clean reinstall, i completely deleted my entire realted drivers and nvidia audio drivers with ddu and made a clean installation, I used both usb A and usb C ports with different slots on the pc just to check if the ports are damaged or anything, i even changed my os from windows 10 to windows 11 thinking maybe its the reason but nothing changed the same problem continues im definitely sure that the error is happening because of the registry/licence of the drivers latest update because its not compatible on some level with armoury crate. Also on an another not the dolby access on my laptop did not recognize the asus rog delta s headset after the firmware update i made on the armoury crate told me to plug a device that is registered on the dolby access program. Just to clarify the problem is not caused by the armoury crate, i am sure it is caused by the headset firmware update "in" the armoury crate program. Please do check the latest update and fix this as soon as possible or release the previous version back. and please do check the screenshots i attached 

Screenshot 2024-01-06 004748.png

Screenshot (3).png

Screenshot (4).png

Screenshot (5).png

Screenshot (6).png

Screenshot (7).png

Screenshot (8).png

Screenshot (9).png

Screenshot 2024-01-06 004617.png

         

 

P.S

Delta S rescue fw is not working either

Herls
Level 8

I am also having the same problem, I'm using a wired Delta S and after the 1/4 update my audio sounds like absolute dog ******. I will be making my own post to try and get their attention.

AthamaS
Level 8

Also posted it on reddit hopefully someone somewhere cares

no_mad
Level 8

I am also having the same problem, I'm using a wired Delta S

Mastervultanuz
Level 8

Well i got a temporary solution or maybe permanent?
I was looking at the past issue from 2022 where nearly all ROG headset where affected with basically the same problem and i found something (thanks to copilot because i remember something armoury II was the original solution, so why not trying a full package offline installation) then i got a link to the Armoury Crate Full package Armoury Crate | ROG México

ALSO!!!
This is extra information MX page from ASUS is newer than US page of armoury crate

Before everything i uninstalled the actual armoury crate, then i remove the bongivi driver from device manager, now i installed armoury full and i select only my headset, because i have more asus products and i restarted again and now everything works also look the version of the SDK


image.png

 

Also i got a problem on my first try on Tidal, but now everything is working also MQA working fineimage (2).png