cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Delta Wireless Failing to connect after update.

SpiderGuitar
Level 8

Ever since I updated my headset it hasn't been able to connect with the dongle. I tried to uninstall and reinstall the drivers, but that didn't work either. It wants me to do a device Firmware update, but the update keeps failing. It tells me to connect my headset via USB and I do. It sends my headset to PC mode, but during the installation possess it disconnects, because I hear the words PC mode again, and the then update fails.

653 Views
2 REPLIES 2

Dyriks
Level 7

I am writing to address the same issue. However, it happened a month after I updated mine. I woke up to find out that my dongle is not pairing with my headset.

The current update for my headset is version 0.0.0.16, date: 2023/05/15.
Armory Crate is version: 5.6.8.0

I am unable to update the headset due to it's unable to pair using 2.4ghz.
I have tried to connect the dongle to the usb without luck, the headset is even unable to pair with my phone using 2.4ghz.

As far as I know, the last update I did went problem free, there was no indication that anything went wrong. I had no power outage and my headset was above 80% power.

I did not connect anything to the computer since the update, and it was working fine 2am last night (paris time).

reszeg111
Level 8

I have the same problem too.I tried to update from another PC with fresh windows, didn't work.

Maybe the firmware version is buggy. Can i update an older firmware verison somehow?