cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Delta needs a firmware update above v152

Spyke9129
Level 8

Hi All,

Anyone else having issues with ROG Delta headset with the firmware version of v152? Everytime Armoury Crate updates the firmware to v152 I always loose to ability to change any sort of EQ or Bass or any other settings on the Delta page of Armoury Crate. Including the microphone settings. The only firmware version that's working for me with the latest Armoury Crate software is v038. I also have one firmware which is probably v150 but it's not working either. At first I thought my Realtek Audio driver interferes with the sound, even when I own a B550-E Gaming motherboard and the driver is from Asus support site. Turned out it's not. It's the firmware. So I hope any official dev from Asus will see this post, as the headset needs an update ASAP because it's unusable! :disappointed_face: 

361 Views
9 REPLIES 9

Nate152
Moderator

Hello Spyke9129

Check Armoury Crate, you should get an update to resolve the audio controls issue.

 

 

 

The firmware upgrade is the reason why I got the issue at the first place. v152 is bad! Period. I've found a v150 and a v39 version firmware. None of them worked.  Also a v38 which actually worked, but after I fixed the audio problem caused by the B550-E Gaming motherboards driver, even the v38 stopped working completely, including the AI noise cancellation. At this point a few days ago I sent back the headset for a service or something. It's either having hardware issues, or the B550-E's driver is faulty (even when I downloaded from Asus's website), or the headset's firmware is faulty, or both. Also, the force of Sonic Studio apps is nonsense. And the fact that the driver files created for the ROG Delta headset are not made by Asus. As I noticed the manufacturer company is a third party. Which is kind of a shame.

Nate152
Moderator

I'm using the ROG Delta S Animate.

There was an issue where we lost audio control, presets, EQ, etc... with the last update, but it's been fixed with a new update that was released on 01-11-2023 which was yesterday. At least that's when I got the update.

 

 

 

 

By "update" what do you mean? Update on the Armoury Crate software or the firmware? I can't check if the ROG Delta got any update, since, as I said I sent it back, so yea. 😞 But it's also a question if even the ROG Delta received any update. Maybe the Delta S Animate did receive it. But in any case I'm not satisfied with the headset sound's either. Also it's kinda wierd if I set an EQ on armoury crate then geforce experience recorded my gameplay videos using that EQ, completely ruining the videos. Even if I receive my fixed headset, or a swap, I'm gonna sell it. 😞 Very big disappointment in Asus headset,  and this is coming from a guy who used many Asus products. I have Flare II Animate, ROG Pugio, B550-E Gaming, ROG RTX 3070 Ti, I used Asus Cerberus keyboard and mouse too, etc.

Nate152
Moderator

The update was for the ROG Delta S Animate and I'm sure the ROG Delta S got the update too as others were reporting the same.

Before this update, the two end sliders on the EQ were non functional. With this new update, the two end sliders are now working. Because of this, it may throw off the sound of your previous presets.

Because we can now use those end sliders, this is able to give us more precise treble and bass.

 

 

The ROG Delta and the ROG Delta S is not the same product. ROG Delta is the original first model as far as I know, also had the best mic on the line. For you only 2 lines were not working? For me the complete handling in Armoury Crate not works. 😛 Not just the EQ, the bass, the noise related sliders, the presets. None of them were working, even when I used the driver provided by the Asus website. So yea.

Nate152
Moderator

Yeah, we pretty much lost all audio control with that last update.

Seeing how your headset is in the ROG Delta line up and you lost audio control as well, I suspect it got the update too. 

You had mentioned about being forced Sonic Studio apps? That seems odd as I never got that.

Have you installed the motherboard audio driver? You shouldn't need to install it for the ROG Delta. This is possibly why you could be getting the forced Sonic Studio apps?

All I install is the motherboard chipset driver and Armoury Crate to use the ROG Delta S Animate.

 

 

 

 

 

The problem is that I had the headset for almost a year and even when I purchased I had the issue. I just found a workaround to solve it. So it's not a recent update that caused the issue. The only thing worked for me is to downgrade the firmware. Nothing else.

Yes, motherboard audio driver provided by Asus on the B550-E Gaming's support site. With that I also got the Realtek Audio Controller app and if I had any EQ activated my speakers would not perform any sound. (Talking about desktop speaker here, not the headset.) The only thing here that worked for me is if I blocked the whole EQ completely in Realtek Audio Control app, then I had sound on my desktop speakers again. Of course, enabling the EQ back in Realtek Audio Control app did not have any effect towards the ROG Delta headset, so that was not the reason. Thank you for trying though, but for now I think I'm just gonna wait out what the service will do with the headset. :3

Nate152
Moderator

All right, this sounds good.

I'd be interested to know what the service center says about your ROG Delta headset.