cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Go 2.4 virtual surround not working.

Dirk199
Level 7

Hi Everyone. 

So I recently upgraded my pc and did a fresh windows install as well. 

Now Armory Crate doesn't enable virtual surround sound properly and when I test it within the app say on the side right the left side also makes a slight sound and on armory crate none of the channels is showing to play sound except for front left and front right.(sound is still coming out but just displayed on FR and FL when I try to test say RR or RL}

I've updated windows, all realtek drivers and uninstalled and reinstalled armory crate and updated everything on there as well. 

Have gone into my windows settings and can't see anything wrong as I tried everything from turning on spatial sound to turning it off, checked audio device settings and everything seems to be in order.

The headset worked perfectly on my previous build so have no idea what is causing the issue.

If anyone has some advice or have a solution I would highly appreciate it. 

Current setup;

1Tb nvme (c:/os drive) 

512Gb nvme

1Tb ssd

32Gb Ram

Msi B550 gaming plus mpg

Asus rog strix Rx 5500 XT

650W psu

Windows 11 Home

52 Views
0 REPLIES 0