Showing results for 
Search instead for 
Did you mean: 

Nvidia HD-Audio driver installation fails

Level 9

Problem Description:

I recently purchased an Asus ROG Strix RTX4090 OC. After I assembled my new PC and wanted to install the Nvidia graphics driver, I noticed that the installation unfortunately kept failing at the "HD audio" point. The log file states that the installation is blocked due to a policy. Attached is the excerpt:

!!! pol: The device is explicitly restricted by the following policy settings:
!!! pol: [-] Restricted Hardware or Compatible ID: HDAUDIO\FUNC_01&VEN_10DE&DEV_00A3&SUBSYS_10438932
!!! pol: {Device installation policy check [HDAUDIO\FUNC_01&VEN_10DE&DEV_00A3&SUBSYS_10438932&REV_1001\5&165CF100&0&0001] exit(0xe0000248)}
!!! dvi: Installation of device is blocked by policy!
dvi: Device Status: 0x01802400 [0x1c]

I have carried out all experiments. These include the officially listed version 537.13 from Asus and the latest from Nvidia 546.17. I also tried to install the oldest one listed by Nvidia. All without success. I also used Nvidia's driver cleanup tool as well as external providers who remove the drivers without leaving any residue. Everything is also hopeless.

Cause of problem:

After reinstalling Windows several times (Windows 11 64bit) and carrying out extensive testing, I discovered the cause of the problem:

If you want to install the Nvidia graphics drivers before downloading Armory Crate, all drivers will install without any problems.
However, if you want to reinstall or update the NVIDIA drivers after the Armory Crate installation, you get the error message that the HD audio driver installation failed. After inspecting the log file, it immediately becomes clear that a registry policy, as described above, is refusing to install the “audio driver device”.
If you now search in the Windows Registry Editor for the HD Audio driver/device name that failed (HDAUDIO\FUNC_01&VEN_10DE&DEV_00A3&SUBSYS_10438932) you will quickly find it under the registry path: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeviceInstall\Restrictions\DenyDeviceIDs
Exactly this “device/driver” is locked/blocked. If you remove/delete this registry entry as a test, the HD audio driver installation works without any problems.
That's why I reinstalled Windows again and checked whether this registry entry was already present at the factory or whether it would be added later. Result? This entry does not exist as standard. So I opened the Registry Editor Live and installed Armory Crate. And lo and behold!: the blocking registry entry is added live during the Armory Crate installation.

So the problem is 100% due to the Armory Crate software. If you now research further in the registry editor, you will also find out that as soon as Armory Crate is installed, other different drivers and registry entries are also installed, including under the regsitry path: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Bongiovi\Motherboard\BlockedDevices. The (HDAUDIO\FUNC_01&VEN_10DE&DEV_00A3&SUBSYS_10438932) is also listed as an entry under this path. If you now search for “Bongiovi” on the internet, you will find that “Bongiovi acoustics” is a company that works with acoustics/audio and their “software/technology” is used by Asus motherboards in their sound chips. So Armory Crate deliberately creates all the registry entries because it is already wanted in the mainboard path.

Overall, Asus needs a fix for their Armory Crate software as soon as possible! From what I've heard from dozens of "victims", your Z790 motherboards stand out for me (probably because of the built-in sound chips).
Now I can at least tell you that it is definitely not a hardware problem, but a software problem.

It is not clear to me why this registry entry is added! I have already passed the problem on to ASUS and it is now being investigated in Taiwan.

My temporary quick fix until a solution comes from Asus:

Disclaimer: (Do at your own risk, making changes to registry files without knowledge can generally lead to system errors)
Only to be used if you want the audio output via a monitor (build-in speaker). Otherwise the NVIDIA HD-Audio drivers are not needed!

- 1. Press Windows + R

- 2. Enter “regedit” (without the “”)

- 3. After the registry editor has opened, enter this path in the search path (between the “File” tab and the computer icon below it): “Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeviceInstall\Restrictions\DenyDeviceIDs” (without the “”)

- 4. Now a window will open on the right. There should be a file here that contains the name “1” and the value: “HDAUDIO\FUNC_01&VEN_10DE&DEV_00A3&SUBSYS_10438932”.

- (Optional security): Before continuing with step 5, I recommend saving this registry file for security reasons. To do this, select this registry entry, then click “File” -> “Export” and then save it individually.

- 5. Delete this registry entry by right-clicking on “1” and then selecting “Delete”.

- 6. Restart your computer (registry changes are only applied after restarts).

- 6. Now when installing the NVIDIA driver, please select “custom installation” and then “clean installation”. The installation should now be successful.

- (Optional security): After successful NVIDIA HD audio driver installation, the previously exported registry file can be opened and then added again. The computer must then be restarted again. I would personally leave this in until Asus fixes it.

I hope I could help you!


UPDATE: I was informed by Asus customer service Germany that the cause I found was correct. It is the Bongiovi SDK of the mainboard. A fix/update for Armoury Crate will be released to address the issue.


Customer Service Agent

Hi @Ma2002rio ,

We apologize for any inconvenience this may cause. We have sent you messege.
Please kindly check the top right corner in the PM inbox.

Thank you!

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

hi, @Aureliannn_ROG with the new nvidia drivers i have the same problem..

Having the same exact problem as well

Level 8

Hello @Aureliannn_ROG I have the same also not only with audio drivers but with physx also

Level 8

After following the instructions of @Ma2002rio physx and hdaudio was installed thanks mate.Pls Asus fix this.

Nice to hear that my solution worked for you 👍🏻 Have fun! And yes, that's still taking time, Asus reported back to me that other problems occurred when Asus did check the new fix-update (BongioviSDK) version 3.00.17. That's why we still have to be patient.

Level 7

Thank you so much, this solved the issue for me, I have been struggling for 4 days and now all solved, thanks a lot !

Level 7

This resolved my issue and I can confirm after testing that installing the drivers from any source normally works after removing those keys. I created a post on the microsoft forums under drivers for 11 that credits you and outlines the jist of the fix for other users.

gg; if I could give you 1000 kudos I would!

Level 9

UPDATE January 16, 2024: Asus has now released an update for your motherboards on January 16, 2024. You can find the update in Armoury Crate. To do this, go to the settings (at the bottom left on the gear symbol) of Armory Crate. You will then find the “Update Center” tab. Now you should find the update for your motherboard. After the update has been successfully installed, please restart your computer. If you haven't received an update yet, you can use my procedure temporarily. In the "Update Center" tab you can also see which device SDK version is installed by opening your mainboard. For my ROG Maximus Z790 Dark Hero, the new device SDK version 3.00.21 fixes the problem. All registry entries and other files will be fixed.