cancel
Showing results for 
Search instead for 
Did you mean: 

Help - 4090 tuf not recognised

Unknown48
Level 7

Hello, apologies if this isn't posted in the correct section. I built my own PC last year using a i9 13900k cpu, z790 strix mobo and a 3080 fe. I have bought a 4090 tuf to replace the 3080 that I sold on however, when I've installed it and using a 12vhpwr native cable with a 1200w psu I'm unable to get it to work. 

I'm using a HDMI cable however the only image I can get is via the motherboard where I believe its using the CPU built in. Windows doesn't find the 4090 I'm unable to download any drivers for it either. I have removed all previous drivers and I'm at a loss with what else to do. 

I have updated the bios to the latest one and the RGB is on the 4090 however, a red light on the gpu stays on when the system is on. I've now ordered another power cable incase its that and a DP cable to try instead of the hdmi. 

Any suggestions what else to do? 

107 Views
1 REPLY 1

DosBlade
Level 7

I am sure this  is not it but did you try and I don't know the TUF but I went through 3 Strix z790 gaming dr. 1st one would not boot (4090) unless I changed it to 8x8x and all 4 memory slots worked. . 2nd one booted up fine x16 but memory only B1B2 worked. I just got the 3rd one. All memory work but it will not boot unless I change to 8x8x. OMG..so you might want to try that? I am sure its not it.. reset bios?