Showing results for 
Search instead for 
Did you mean: 

GPU Tweak III Hard locks PC

Level 7

I am having the exact same problem this user is having: GPU Tweak III Hard freezes my PC - Republic of Gamers Forum - 959945 (

This issue has been going for a while and I cannot use GPU Tweak III app at all. It seems to be only working under load (playing games)
but as soon as PC enters lower power state e.g. when I browse the web, watch YT, Twitch etc. My PC randomly hard freezes and the only way to fix it is to manually restart it.  I've tried leaving the app run with default setting. Same issue, as long as it runs in the background I get random freeze. 

I am 100% sure the culprit is the app because I had it disabled for several weeks and used my PC regularly with no issues at all. My system was super stable. Then yesterday I made it launch with Windows again and not long after doing some light work my PC completely froze.

Please fix your app ASUS. I really want to use it for the Ext. fan support and applying custom undervolt.

My specs:
CPU: AMD Ryzen 7 5800X3D
MBOARD: ROG Strix B550-I Gaming
GPU: ROG Strix RTX 3090 O24
GPU Tweak III version:


Level 8

My problem was never solved. I still have that issue and coming back in here just to verify if there's any fix ... MONTHS later, i saw your post.

Too bad they cant work it out, we're beta testers mate...

Level 7

Yeah, I'm no longer running their buggy app and my rig hasn't crashed or froze a single time for weeks. It's a shame you are only able to control your external fans connected to GPU headers via this app. Otherwise I'd stick with MSI Afterburner and never look back.
Asus reached out to me via email saying they will try to replicate the problem but I have doubts they will take a deep investigation regarding this.

We both have 5800x3D and a B550 motherboard ... might be something, who knows what!

Are you using Windows 10 like me or 11 ?

Could be the cause. It's 100% their app problem. Poorly coded and it feels bloated taking almost 1 Gig.
Their curve optimizer still has mind of it's own and most of the time doesn't stay to what you set it to be.
I'm on Win 10 Pro.

I'll test it out extensively on win11 at some point but I have no spare time for troubleshooting crap out of a product i paid 1000euros.

Hopefully they'll fix it in a few years ...

Please report your findings.

I tried to BUMP my topic once more but i can't reply in there for some reason...

That's how i ended up finding your's .... I dont know if that'll be open to report anything.

On the other hand, this forum platform is "strange"... I'm not a robot ... yeah right!

Have you tried contacting ASUS directly via email or filing in their support form on GPU Tweak III website regarding this issue?