Showing results for 
Search instead for 
Did you mean: 

Asus Strix 4090 OC Artifacts on Boot/Bios

Level 7

Having issues with the Strix 4090 OC I have it is showing artifacts on boot and in bios but not when windows shows up in windows its fine but it just displays artifacts when booting/bios do i have a bad card or motherboard possibly? 

I enabled csm in the bios and I was able to get into the bios just fine with using the gpu.

I disabled csm and was not able to see anything in the bios due to artifacts as seen in the image below. 

Update** I tried hdmi and i could get in the bios just fine not artifacts. 

Update again* it might be a monitor/compatibility issue not sure if this can be fixed? i tried a different monitor and it worked fine(screenshot below)asus vg279 monitor work fineasus vg279 monitor work fine

Might be an issue with monitor/gpu  ill attach a picture ofweird resolution display port issueweird resolution display port issue the weird resolution it comes up as (not sure how to fix that) 


Motherboard: Maximus z790 Hero

Bios: 1202

GPU: Strix 4090 OC

Memory:64gb gskill 6400

PSU: HX1500I

PXL_20230731_024206009.MP - Copy.jpg


Customer Service Agent

Hello, @bmcbride1991 

Thank you for providing the information and images.
Based on your description, with the same hardware configuration, BIOS version, and using the same cables, cross-tested with the ASUS VG279 but did not experience any flickering issues while in BIOS or POST before entering the OS.
May I ask what brand and model your original monitor is?
Could you please help confirm the BIOS version, the connection method between the graphics card and the monitor, the version of the GPU, and Intel ME?

Thank you.

Bios Version 1202(latest)

Brand of monitor: Asus(VG248QG) I have 3 of these doing the same thing.

Connection Method: Display Port(not working as shown in the image above) HDMI(works)

Intel ME: Latest version

GPU: Strix 4090 OC  V2.1 bios @Jiaszzz_ROG 

Customer Service Agent

Hello, @bmcbride1991 

May I inquire if your current CPU supports an integrated GPU?
If so, could you please attempt to directly connect the monitor to the motherboard and check whether using the integrated GPU results in the same display anomalies?
Or, please try cross-testing with a different graphics card to further identify any potential hardware issues.

Thank you.

Hello @Jiaszzz_ROG  yes current CPU supports it intel 13900k and there is no display anomaly when using the integrated gpu. 

I'm sure it's probably just a monitor/gpu incompatibility (doesn't make much sense) since HDMI works if I plug it in but DisplayPort does not(boot/bios) in Windows it works all the time. 

DisplayPort does work on another monitor though. 

Customer Service Agent

Hello, @bmcbride1991 

Thank you for providing the test results.
After consulting with the relevant departments, we recommend that you send your graphics card for repair to further diagnose any potential issues with the graphics card itself.
Since you mentioned that testing with other monitors yielded normal results, it's advisable to consider the option of sending it for repair.
If necessary, please refer to ASUS - service center locations and proceed with the RMA process.

Thank you.

@Jiaszzz_ROG  "Since you mentioned that testing with other monitors yielded normal results, it's advisable to consider the option of sending it for repair."

Since testing with another monitor that yielded normal results prove that the GPU is fine, and the issue lies with monitor display incompatibility or an issue with bios?

@Jiaszzz_ROG might be a possible monitor issue see relevant issue here the resolution of 644x3321 I have 3 of these doing the same thing and the other monitor i tested worked fine. 

see relevant post here. 

problematic DisplayPort output during UEFI/BIOS/PO... - Republic of Gamers Forum - 840697 (

Customer Service Agent

Hello, @bmcbride1991 

I'm a bit unsure. If the display works normally after entering the system, how did you determine that it might be a screen issue?
If that's the case, we would recommend you refer to [Motherboard] Troubleshooting - No Power/No Boot/No Display and test with minimal components to isolate the possible cause.

Thank you.

Coming back to this it might not be a monitor issue. When trying out the monitor that it works on (VG279) I had the display artifact once but then it actually stopped artifacting and displayed correctly.  I'm thinking it might have to do with UEFI Bios/ Graphics VBIOS resolution or something to do with the DisplayPort on the monitors being 1.2 and the graphics card is 1.4a (DisplayPort should be backwards compatible though). Possibly have to wait for a vbios update or motherboard bios update to fix it possibly🤔😔