cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Delta S Eva Audio Optimizations not working at all

DauntingChief05
Level 7

Can anyone help me please?

None of the settings I make in Armory Crate's Sound Optimizations apply to my Rog Delta S EVA.
It doesn't matter if I adjust bass, compression, equalizer, reverb, nothing happens.

I have windows 11 Pro [22631]. My motherboard is an Asus Rog Strix B550-F Gaming Wifi II.

  • I have all Armory Crate updates installed and also Windows updates.
  • Uninstalled Armory Crate using the Asus wizard and then reinstalled.
  • Reinstalled the headphone drivers.
  • Started Windows with only Asus services enabled and nothing works.

This is the list of all the services installed for Armoury Crate
---- -------
Armoury Crate UWP App 5.8.8.0
ROG Live Service 2.3.16.0
Aura Service (Lighting Service) 3.07.43
Armoury Crate lite service 5.8.8
Aura Wallpaper Service Not installed
Aura SDK 3.04.42
ArmouryDevice 4.1.1.1
ASUS AIOFan HAL 1.2.16.0
ASUS AURA Extension Card HAL 1.1.0.20
ASUS AURA Motherboard HAL 1.3.9.6
ASUS Ambient HAL 2.7.0.0
ASUS Keyboard HAL 1.2.55.0
ASUS Mouse HAL 1.2.0.84
AacAudioHal 1.3.62.0
KingstonDram 1.1.33
AURA DRAM Component 1.1.25
ENE RGB HAL 1.1.48.6
ENE_EHD_M2_HAL 1.0.10.3
PHISON HAL 1.0.9.0
Patriot Viper DRAM RGB 1.0.9.8
Patriot Viper M2 SSD RGB 1.1.0.3
Universal Holtek RGB DRAM 1.0.0.7
WD_BLACK AN1500 1.0.14.0
AIOFanSDK 3.00.10
AudioSDK 3.01.19
KeyboardSDK 3.00.47
MainSDK 2.01.11
MainSDKPlugin 111.0.1661.54
MbLedSDK 3.00.22
MouseSDK 3.01.29
Armoury Crate Plugin - Aio 2.0.7
Armoury Crate Plugin - Fan Extension Card 1.2.1
Armoury Crate Plugin - Gamepad 2.0.2
Armoury Crate Plugin - Headset 1.2.12
Armoury Crate Plugin - Keyboard 1.2.30
Armoury Crate Plugin - Motherboard 1.2.16
Armoury Crate Plugin - Mouse 2.3.1
Armoury Crate Plugin - Mousepad 1.2.0
Armoury Crate Plugin - ROG FAN XPERT 4 2.0.2
Armoury Crate Plugin - UnifyDongle 0.0.5
ASUS Motherboard 4.01.38
ROG DELTA S EVA EDITION 4.01.02
ROG KERIS WIRELESS 4.01.18
ROG KERIS WIRELESS (2.4GHz) 4.01.18
ROG RYUO 4.01.23
ROG STRIX SCOPE RX 4.01.14

Screenshot (35).png

Screenshot 2024-03-23 145835.png

270 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MonsterOfGaming
Level 8

Hey, I had the exact same problem with my Delta S Animate. Todays firmware update in Armoury Crate fixed it for me. Give it a try 🙂

View solution in original post

3 REPLIES 3

MonsterOfGaming
Level 8

Hey, I had the exact same problem with my Delta S Animate. Todays firmware update in Armoury Crate fixed it for me. Give it a try 🙂

Thanks so much. I have applied the new update and the issue has gone. 😁

Hi @DauntingChief05 @MonsterOfGaming ,

Thank you very much for your feedback!
We are pleased the new firmware help you resolve the issue. 
If you have any other questions or need further assistance, please feel free to ask.
We are here to assist you.

Thank you.