cancel
Showing results for 
Search instead for 
Did you mean: 

Delta S Wireless not working in 2.4

Silently
Level 8

Hello,

I bought td Delta S Wireless in December, and I've already had to send it back in February for another problem (it wouldn't start up at all). I got a fresh new headset exchange.

Since this morning, the headset no longer works in 2.4, it only works in BT.

When I switch it on in 2.4, there's a little "beep", but that's all. It's recognized, but that's all. No sound. No mic. The settings are not accessible. The blue LED flashes.
In BT there's a little "beep" and then "connected". The headset works. The blue LED is steady.

When I plug it in, it says "PC Mode" but that's all. The updates (I formatted the whole PC today, for this problem) are in error, it asks me to connect the cable and the dongle, both are connected.

I think the problem is with the dongle. I haven't seen any way to factory reset either the headset or the dongle, this feature isn't provided (for a 200€ headset).

Item Version
---- -------
Armoury Crate UWP App 5.6.8.0
ROG Live Service 2.1.4.0
Aura Service (Lighting Service) 3.07.17
Armoury Crate service 5.6.8
Aura Wallpaper Service Non installée
Aura SDK 3.04.32
ASUS Aac_NBDT HAL 2.5.29.0
ASUS Mouse Extern HAL 1.2.0.6
ASUS Mouse HAL 1.2.0.58
AacAudioHal 1.3.50.0

16,374 Views
125 REPLIES 125

im also having the 2.4ghz not connecting, started 3 days ago 

TonyDY_WANG
Level 8

Hi @Jiaszzz_ROG  ,My headset have same problem, any solution can fix it ?

Jiaszzz_ROG
Customer Service Agent

Hello, @testament86 and @TonyDY_WANG 

Please check the top right corner of the screen and kindly share the details requested in the PM inbox.

Thank you!

sharing complete hardware info & software config details will help us better understand the issue 🙂

Scusate anch’io ho lo stesso problema ma qualcuno ha risolto?

TonyDY_WANG
Level 8

Hi @Jiaszzz_ROG,

My headset 2.4ghz working fine now, thanks for your help.

Comment tu as fait ? Malgré la procédure c'est toujours bloquer.. Peux-tu m'expliquer ?

Come hai risolto?

No-Secret
Level 7

Hello!

I have exactly the same problem with my Delta S Wireless, what should I do to fix it?

Zinbalu
Level 8

Hello, @Jiaszzz_ROG

I have the same problem since today with my ROG Delta S Wireless. Can you help me fix it?

GalaxyDranzer
Level 7

Hello, I have the same problem, Wi-Fi 2.4 mode does not work. I only have bluetooth mode that works fine. Armory Crate asks me to connect the helmet to the USB key (USB-C Dongle) but it is not possible for me to do so. Help me please